Bug 51302 - network card not detected by mii-tool
Summary: network card not detected by mii-tool
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: setup   
(Show other bugs)
Version: roswell
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-09 08:08 UTC by John Sheahan
Modified: 2014-03-17 02:22 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-09 08:08:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Sheahan 2001-08-09 08:08:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010725

Description of problem:
My NIC is not detected by /sbin/mii-tool. As a result install does not
configure the network. I had to chmod -x mii-tool and edit
/etc/sysconfig/network-scripts/network-functions so that check_link_down
returns 1 if mii-tool is not found.
I think there are two issues here.
my NIC is a  Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139
(rev 10) running 100baset onto a small switch. It works fine. 
however : [root@wattle john]# /sbin/mii-tool
eth0: 10 Mbit, half duplex, no link



How reproducible:
Always

Steps to Reproduce:
1. run /sbin/mii-tool on this particular NIC
2.
3.
	

Actual Results:  [root@wattle john]# /sbin/mii-tool
eth0: 10 Mbit, half duplex, no link


Expected Results:  [root@wattle john]# /sbin/ip link show
1: lo: <LOOPBACK,UP> mtu 16436 qdisc noqueue 
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,NOTRAILERS,UP> mtu 1500 qdisc pfifo_fast qlen 100
    link/ether 00:40:c7:81:8d:53 brd ff:ff:ff:ff:ff:ff


I don't know how to get the media speed for this NIC offhand, but my switch
insists it is running at 100MHz, the link is definitely up since this
browser is using it.

Additional info:

There is no bugzilla category for mii-yool

Comment 1 Bill Nottingham 2001-08-09 15:05:24 UTC
The code that checks mii-tool is removed from initscripts-6.12-1.


Note You need to log in before you can comment on or make changes to this bug.