Bug 51304 - The definition of function 'vi' is printed out when login (zsh)
Summary: The definition of function 'vi' is printed out when login (zsh)
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: vim   
(Show other bugs)
Version: roswell
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-09 08:54 UTC by Satoru SATOH
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-09 08:54:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Satoru SATOH 2001-08-09 08:54:16 UTC
Description of Problem:
The definition of function 'vi' in /etc/profile.d/vim.sh is printed out
when login with zsh.


How Reproducible:everytime


Steps to Reproduce:
1. change any user's shell to zsh
2. logout and login as this user

Actual Results:
The following messages are printed out:

localhost login: ssato
Password: 
Last Login: Thu Aug   9 16:50:48 on tty1
vi () {                                    <--  
     /usr/bin/vim $@                       <-- this
}                                          <--
localhost$ 

Expected Results:
That function is defined quietly.

Additional Information:

Comment 1 Bernhard Rosenkraenzer 2001-08-09 08:59:24 UTC
vim.sh hasn't existed since 5.8-5 because a couple of people with too much 
influence don't like vim-enhanced.



Note You need to log in before you can comment on or make changes to this bug.