Bug 51315 - Sendmail fails to read files defined in /etc/aliases
Summary: Sendmail fails to read files defined in /etc/aliases
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sendmail   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-09 13:09 UTC by Yoda
Modified: 2007-04-18 16:35 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-09 13:09:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Yoda 2001-08-09 13:09:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.18 i686)

Description of problem:
Defining a mailing list to be read from a file in /etc/aliases fails.
Sendmail treats it as a email address not as a list.

mailinglist::include:/usr/local/etc/mailingList

This is only a problem in RH7.1.  RH7.0 works OK

How reproducible:
Always

Steps to Reproduce:
1. enter alias in /etc/aliases 
mailinglist:include:/usr/local/etc/mailinglist
2. run newaliases  (no errors reported)
3. sendmail -bv mailinglist 
	

Actual Results:  :include:/usr/local/etc/localadmin.txt... User unknown

Expected Results:  mailinglist@freddofrog.com.au... deliverable: mailer
esmtp, host freddofrog.com.au., user freddofrog@bigpond.com.au

Additional info:

Comment 1 Florian La Roche 2001-08-23 07:30:16 UTC
Works for me with:
mailinglist: :include: /etc/mailinglist

Florian La Roche


Comment 2 Yoda 2001-08-24 11:04:00 UTC
Not sure now we downgraded to the RH7.0 one.
However the sendmail man page says"
poets: ":include:/usr/local/lib/poets.list"
Maybe the quotes are the problem?


Note You need to log in before you can comment on or make changes to this bug.