Bug 51316 - XFree86-xfs "just doesn't work"
Summary: XFree86-xfs "just doesn't work"
Status: CLOSED DUPLICATE of bug 51033
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 51700 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-09 13:10 UTC by Jonathan Kamens
Modified: 2007-04-18 16:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-09 13:11:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace output from failed server start-up with xfs 0.9.11 (2.19 KB, text/plain)
2001-08-09 13:11 UTC, Jonathan Kamens
no flags Details
strace output from successful server start-up with xfs 0.9.4 (8.13 KB, text/plain)
2001-08-09 13:11 UTC, Jonathan Kamens
no flags Details

Description Jonathan Kamens 2001-08-09 13:10:26 UTC
I upgraded to the current Rawhide, i.e., to:

XFree86-VGA16-3.3.6-40
XFree86-devel-4.1.0-0.9.11
XFree86-75dpi-fonts-4.1.0-0.9.11
XFree86-compat-libs-4.0.3-2
XFree86-doc-4.1.0-0.9.11
XFree86-Xvfb-4.1.0-0.9.11
XFree86-twm-4.1.0-0.9.11
XFree86-xf86cfg-4.1.0-0.9.11
XFree86-xfs-4.1.0-0.9.11
XFree86-Mach64-3.3.6-40
XFree86-4.1.0-0.9.11
XFree86-libs-4.1.0-0.9.11
XFree86-100dpi-fonts-4.1.0-0.9.11
XFree86-tools-4.1.0-0.9.11

After doing so, I could not "xinit" -- the server reports that it can't
open font "fixed".  This, despite the fact that "fslsfonts -server
unix/:7100 -fn fixed" lists it just fine.  Reverting to
XFree86-xfs-4.1.0-0.9.4 made the problem go away.

I can't figure out how to debug this easily, since xfs doesn't have any
sort of debugging options as far as I can tell.  What I did do is capture
strace output from xfs when it failed in 0.9.11 and succeeded in 0.9.4. 
I'll attach them both, in case they're helpful.

Comment 1 Jonathan Kamens 2001-08-09 13:11:00 UTC
Created attachment 26996 [details]
strace output from failed server start-up with xfs 0.9.11

Comment 2 Jonathan Kamens 2001-08-09 13:11:35 UTC
Created attachment 26997 [details]
strace output from successful server start-up with xfs 0.9.4

Comment 3 Jonathan Kamens 2001-08-09 16:52:38 UTC

*** This bug has been marked as a duplicate of 51033 ***

Comment 4 Tim Waugh 2001-08-24 13:31:41 UTC
*** Bug 51700 has been marked as a duplicate of this bug. ***

Comment 5 Nick Simicich 2001-08-28 15:25:03 UTC
This bug is closed as a duplicate of a hidden bug.  A quote from Mike Harris of 
Redhat:

If you encounter any bugs like this, let us know so we can either 
unmark the confidential bug (some are wrongly marked, or change 
over time), or we can reverse the duplicate marking, or otherwise 
resolve the issue.



Note You need to log in before you can comment on or make changes to this bug.