Bug 51337 - rhn_check produces errors
rhn_check produces errors
Status: CLOSED CURRENTRELEASE
Product: Red Hat Public Beta
Classification: Retired
Component: up2date (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-09 12:52 EDT by Michael Young
Modified: 2015-01-07 18:50 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-22 05:02:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Young 2001-08-09 12:52:58 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; SunOS 5.6 sun4u)

Description of problem:
If I try to download packages queued via beta.rhns.redhat.com by running
rhn_check, I get the errors below. I am sure I have previously done this
successfully in seawolf.
Traceback (innermost last):
  File "/usr/sbin/rhn_check", line 229, in ?
    handle_action(action)
  File "/usr/sbin/rhn_check", line 153, in handle_action
    response = do_call(method, params)   
  File "/usr/sbin/rhn_check", line 70, in do_call
    method = getMethod.getMethod(method, "/usr/share/rhn/up2date/",
"actions")
  File "/usr/share/rhn/up2date/getMethod.py", line 48, in getMethod
    raise GetMethodException("Action %s could not be found" % methodName)
getMethod.GetMethodException: Action packages.update could not be found


How reproducible:
Always

Steps to Reproduce:
1. run rhn_check
2.
3.
	

Additional info:
Comment 1 Glen Foster 2001-08-09 16:03:39 EDT
We (Red Hat) really need to fix this defect before next release.
Comment 2 Jay Turner 2001-08-09 16:19:28 EDT
Actually, already fixed in the version of up2date that we are testing right now.
 Should be included in the next cut of the beta code.
Comment 3 Cristian Gafton 2001-08-10 16:57:59 EDT
Assigned to the owner of component
Comment 4 Michael Young 2001-08-22 05:02:41 EDT
I can now download and install packages using rhn_check (assuming gpg is turned
off in up2date-config) using the up2date and python-xmlrpc packages which fix
bug 50891 .
Comment 5 Jay Turner 2001-08-22 09:27:10 EDT
Closing out this issue then.

Note You need to log in before you can comment on or make changes to this bug.