Bug 513438 - After kernel update on 23/07/09 NVidia driver is broken
After kernel update on 23/07/09 NVidia driver is broken
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
11
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-23 12:31 EDT by Dennis Schwalb
Modified: 2009-09-03 16:15 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-03 16:00:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dennis Schwalb 2009-07-23 12:31:27 EDT
Description of problem:

I performed a fresh installation of Fedora 11 from the KDE Live CD two days ago. Installation caused no problems, and even after installing the proprietary NVidia graphics driver there was no problem.

Today I performed the updates that KPackgeKit reported, including a kernel update. After reboot the NVidia driver was broken and I could start X only with a maximum resolution of 800x600 (my screen normally does 1920xsth.). Reconfiguring X didn't help. I tried it again with a fresh installation, performing all the updates and installing driver afterwards. The result was the same.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Perform a fresh installation.
2. Run the latest kernel update.
3. Install proprietary NVidia driver.
4. Reboot.

(Steps 2 and 3 can be exchanged. Happens with both, kmod-nvidia and akmod-nvidia.)
  
Actual results:


Expected results:


Additional info:
Comment 1 vafr 2009-09-03 14:34:13 EDT
I have a similar problem but was nt able to startx at all apparently due to an 'API mismatch'.

I have tried to install akmod-nvidia but it seems that this makes no difference.

When using an old kernel all seems ok. I am currently using; 
---
Linux localhost.localdomain 2.6.29.6-217.2.3.fc11.x86_64 #1 SMP Wed Jul 29 16:02:42 EDT 2009 x86_64 x86_64 x86_64 GNU/Linux
---
With this kernel there is no problem.

I believe I have had three kernel updates up to now but was not use any of these in combination with X. 

Logging in as root under any of these new kernels and then running dmesg reveals that there is an API conflict;
---
virbr0: starting userspace STP failed, starting kernel STP
NVRM: API mismatch: the client has the version 185.18.31, but
NVRM: this kernel module has the version 185.18.14.  Please
NVRM: make sure that this kernel module and all NVIDIA driver
NVRM: components have the same version.
SELinux: initialized (dev proc, type proc), uses genfs_contexts
lo: Disabled Privacy Extensions
SELinux: initialized (dev proc, type proc), uses genfs_contexts
skge eth0: enabling interface
ADDRCONF(NETDEV_UP): eth0: link is not ready
skge eth0: Link is up at 100 Mbps, full duplex, flow control both
ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
virbr0: no IPv6 routers present
eth0: no IPv6 routers present
NVRM: API mismatch: the client has the version 185.18.31, but
NVRM: this kernel module has the version 185.18.14.  Please
NVRM: make sure that this kernel module and all NVIDIA driver
NVRM: components have the same version.
--- 

To work around this problem I currently make sure that I have only two kernels installed (the newest 2.6.29.6-217.2.16.fc11.x86_64 and the old one that still works with X) so that if a new kernel update is available/installed I will still be able to boot the old 2.6.29.6-217.2.3.fc11.x86_64 kernel. I do not know what to do when this kernel is no longer available on my system and I do not know how to maintain more than three kernels at a time because this seems to automated somewhere but I do not know how to change this(to say 5 kernels but this is another problem though).   

Hope this will be solved soon because I think my workaround is not a very good long term solution.

Rik
Comment 2 vafr 2009-09-03 14:43:52 EDT
By the way,

I noticed I ***cked up my login because I have made a mistake and used an email address that is of no use because I forgot a '.' and my email address should really start with rf.av 
 
I will try to correct this asap...
Comment 3 vafr 2009-09-03 15:28:49 EDT
By the way,

I noticed I ***cked up my login because I have made a mistake and used an email address that is of no use because I forgot a '.' and my email address should really start with rf.av 
 
I will try to correct this asap...
Comment 4 vafr 2009-09-03 15:46:31 EDT
I'm back on track with my correct email address. Please keep us updated...
Comment 5 Neil Horman 2009-09-03 16:00:02 EDT
sorry, we can't help you, thats not code that we have any visibility into.  You'll need to contact nvidia directly on this issue.
Comment 6 vafr 2009-09-03 16:15:09 EDT
So may I conclude that there is no support to be expected from Fedora with respect to the kmod-nvidia, akmod or nouveau driver???

And if so, what does Fedora suggest that Fedora users should choose as a suitable alternative for the nvidia video card. Or in other words, what video hardware is fully supported by Fedora?

Note You need to log in before you can comment on or make changes to this bug.