Bug 513587 - After update from 3.4.2-11 to 3.4.2-13 no plugins are loaded
After update from 3.4.2-11 to 3.4.2-13 no plugins are loaded
Status: CLOSED DUPLICATE of bug 509616
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-24 07:55 EDT by Felix Schwarz
Modified: 2009-07-24 14:01 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-24 14:01:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Felix Schwarz 2009-07-24 07:55:34 EDT
When I updated to 3.4.2-13 (x86_64), no plugins were loaded. This affected plugins which I installed using the Eclipse update UI as a user (pydev) as well as plugins installed through Fedora's rpms (eclipse-emf-2.4.2-3.fc11.noarch for example). I was not able to re-install these packages because Eclipse's update manager found that the plugins were already installed.

eclipse -clean did not help
eclipse -console showed that the plugins were not loaded.
There are no errors in the log.

By removing all my configurations (rm -rf ~/.eclipse) I could see all the plugins again on a new workspace but re-installing everything is not an option.

I downgraded to 3.4.2-11 and everything works again.
Comment 1 Andrew Overholt 2009-07-24 14:01:41 EDT
This is an upstream bug in the 3.4 series.  It's fixed in 3.5 which will be in Fedora 12.

*** This bug has been marked as a duplicate of bug 509616 ***

Note You need to log in before you can comment on or make changes to this bug.