Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 513667 - Brother HL-1430/1440 Foomatic/gutenprint drivers fail
Brother HL-1430/1440 Foomatic/gutenprint drivers fail
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: foomatic (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
: 506708 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-24 12:58 EDT by Jonathan Ryshpan
Modified: 2009-10-22 11:49 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-22 11:49:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Ryshpan 2009-07-24 12:58:41 EDT
Description of problem:
Brother HL-1440 print drivers: Most don't work at all; one works badly

Version-Release number of selected component (if applicable):
cups-1.4-0.b2.18.fc11.x86_64

How reproducible:
Always

Steps to Reproduce:
Try to print something
  
Actual results:
Strange output.

Expected results:
Normal printing.

Additional info:
The printer database seems to be buggy, at least for the HL-1440 printer.  

System-config-printer allows a number of drivers for the HL-1440
printer.  I tried them all and printed the standard test page. These are
my results.  Everything was done as "su root", which may just possible
have some effect on things.  The bad printers are marked with a *, the
passable one with a o.

      * Brother HL-1440 Foomatic/gutenprint-ijs-simplified.5.2 [en] --
        prints a dark line at the top of the page, which is otherwise
        blank.
      * Brother HL-1440 Foomatic/gutenprint-ijs.5.2 [en] -- prints a
        dark line at the top of the page, which is otherwise blank.
      o Brother HL-1440 Foomatic/hpijs [en] -- seems to work OK.
        However be careful to select U.S. letter size paper (if you live
        in the U.S.)  However graphics print very badly.  Graphic info 
	prints very faintly, as if the printer is printing in draft mode
	which I have NOT selected.
      * Brother HL-1440 Foomatic/hl1250 [en] -- failed completely.
        Message from Cups is "/usr/lib/cups/filter/foomatic-rip failed".
        No output from the printer, not even a blank page.
      * Brother HL-1440 Foomatic/lj4dith [en] -- prints two pages.
        First has garbage at the top, second left upper corner of what
        looks like the test page printed at twice normal scale.
      * Brother HL-1440 Foomatic/ljet4 [en] -- similar to the last but
        with dirty streaks running out from the left side of the page.

I like the Gutenprint drivers in general, so it would be nice to have a
working Gutenprint for the HL-1440, as there was in F-10.
Comment 1 Tim Waugh 2009-07-27 08:21:22 EDT
Thanks for the bug report, and the research.  There are several problems mentioned here.  I'll go through them and give them separate numbers so we know which we are talking about:

1. The driver that gets automatically selected for this printer does not work.  I'd guess that's the reason for your research. :-)  Currently the recommended driver is 'Brother HL-1440 Foomatic/gutenprint-ijs-simplified.5.2', but the same incorrect output is given regardless of whether the simplified PPDs are used.

2. There's some problem to do with paper size selection for hpijs, but you haven't expanded on what exactly that is.

3. You were unable to test the hl1250 driver because of a foomatic bug.

4. The lj4dith and ljet4 drivers give incorrect output for this printer.

Now let's see if we can fix them:

1. To see if the problem is to do with foomatic, please try the 'native' gutenprint drivers.  To do this, install the 'gutenprint-cups' package and try these drivers:

Brother HL-1440 - CUPS+Gutenprint v5.2.3
Brother HL-1440 - CUPS+Gutenprint v5.2.3 Simplified

2. What was the paper size problem you mentioned?

3. Please re-test the 'Brother HL-1440 Foomatic/hl1250' driver after applying the foomatic update issue last week:
  https://admin.fedoraproject.org/updates/F11/FEDORA-2009-7828

Will defer 4 until we know why the recommended driver isn't working.
Comment 2 Jonathan Ryshpan 2009-08-07 13:21:57 EDT
(In reply to comment #1)
Sorry for the delay.  I have only recently got the email from Bugzilla

> 1. To see if the problem is to do with foomatic, please try the 'native'
> gutenprint drivers.  To do this, install the 'gutenprint-cups' package and try
> these drivers:
> 
> Brother HL-1440 - CUPS+Gutenprint v5.2.3
> Brother HL-1440 - CUPS+Gutenprint v5.2.3 Simplified

Both drivers seem to work fine.  Test page and graphics both print well.

> 2. What was the paper size problem you mentioned?

Not a real problem, just a warning to others who may read the entry.  I chose not to import print settings, which causes the paper size to revert to A4.  This can be confusing if you are also having real printer problems.

> 3. Please re-test the 'Brother HL-1440 Foomatic/hl1250' driver after applying
> the foomatic update issue last week:
>   https://admin.fedoraproject.org/updates/F11/FEDORA-2009-7828

This driver also seems to work well.  I assume that this patch got into the normal update system and was brought into my computer a few days ago, since the rpm is no longer at .../updates/F11/FEDORA-2009-7828:
    $ rpm -q foomatic
    foomatic-4.0.2-4.fc11.x86_64
Comment 3 Tim Waugh 2009-08-10 11:06:18 EDT
OK, so '1' is some problem with foomatic.

For '2', what does 'locale' say?  You should never need to alter the default page size when your system locale setting is correct.

3 is fixed now.

So, digging deeper into problem number 1, please update gutenprint to the version from updates-testing:

yum --enablerepo=updates-testing update gutenprint

Then, change the driver to this one:

Brother HL-1440 - Foomatic/gutenprint-ijs-simplified.5.2 [en]

If it is already using that driver, please change it to another, then change it back.

Does it still fail as described?
Comment 4 Jonathan Ryshpan 2009-08-12 17:40:07 EDT
(In reply to comment #3)
> OK, so '1' is some problem with foomatic.
> 
> For '2', what does 'locale' say?  You should never need to alter the default
> page size when your system locale setting is correct.

$ locale
LANG=en_US.UTF-8
LC_CTYPE="POSIX"
LC_NUMERIC="POSIX"
LC_TIME="POSIX"
LC_COLLATE="POSIX"
LC_MONETARY="POSIX"
LC_MESSAGES="POSIX"
LC_PAPER="POSIX"
LC_NAME="POSIX"
LC_ADDRESS="POSIX"
LC_TELEPHONE="POSIX"
LC_MEASUREMENT="POSIX"
LC_IDENTIFICATION="POSIX"
LC_ALL=POSIX

It looks like this problem is caused by 
    LC_PAPER="POSIX"
which should be
    LC_PAPER="us_letter"
or something similar.

$ man locale doesn't have any useful info about LC_PAPER, nor about most of the other LC_* entries.  Where is this info available?  Maybe there should be a place in anaconda to set all this stuff when the system is set up.

> 3 is fixed now.

Yes.  Thanks

> So, digging deeper into problem number 1, please update gutenprint to the
> version from updates-testing:
> 
> yum --enablerepo=updates-testing update gutenprint
> 
> Then, change the driver to this one:
> 
> Brother HL-1440 - Foomatic/gutenprint-ijs-simplified.5.2 [en]
> 
> If it is already using that driver, please change it to another, 
> then change it back.
> 
> Does it still fail as described?  

Doing as you recomment, the entry
  Brother HL-1440 - Foomatic/gutenprint-ijs-simplified.5.2 [en] (recommended)
========> Note (recommended)<========
seems to work fine.
Comment 5 Tim Waugh 2009-08-21 04:53:36 EDT
*** Bug 506708 has been marked as a duplicate of this bug. ***
Comment 6 Tim Waugh 2009-08-21 05:01:31 EDT
(In reply to comment #4)
> LC_ALL=POSIX

Somewhere you have LC_ALL=POSIX, which isn't what you want.

This seems to be the last remaining problem (I just pushed the gutenprint update to stable for Fedora 11).

So what does /etc/sysconfig/i18n contain?
Comment 7 Jonathan Ryshpan 2009-08-21 11:55:46 EDT
(In reply to comment #6)
> (In reply to comment #4)
> > LC_ALL=POSIX
> 
> Somewhere you have LC_ALL=POSIX, which isn't what you want.
> 
> This seems to be the last remaining problem (I just pushed the gutenprint
> update to stable for Fedora 11).
> 
> So what does /etc/sysconfig/i18n contain?  

$ cat /etc/sysconfig/i18n
LANG="en_US.UTF-8"
SYSFONT="latarcyrheb-sun16"

Please let me repeat that locale and i18n (how's that for a totally un-obvious acronym) are totally undocumented in Linux (except for the perl functions) and is (as far as I remember) not set up in the installation process.

Thanks for your help and attention - jon
Comment 8 Tim Waugh 2009-08-22 06:08:56 EDT
Please run this:

python <<"EOF"
import cups
c=cups.Connection()
for p in c.getPrinters().keys ():
  print c.getPrinterAttributes(p).get('natural-language-configured')
EOF

What output do you get?
Comment 9 fred smith 2009-08-22 21:49:43 EDT
FYI, this same problem also affects other Brother printers. I've encountered several of the drivers recommended by the printer configuration tool, that used to work (in ,e.g., F10), do not work in F11. With necessary updates, the drivers described in this entry do work. I'm using a network-attached HL2070N.

the gutenprint driver suggested produces the bitmap images on the test page in such a way that they don't look nearly as nice as they do with the foomatic driver.

(I'm not the OP, but...) for your request in comment #8 here's the output I get:

en_US
en_US
en_US
Comment 10 Jonathan Ryshpan 2009-08-23 00:54:48 EDT
(In reply to comment #8)
> Please run this:
> 
> python <<"EOF"
> import cups
> c=cups.Connection()
> for p in c.getPrinters().keys ():
>   print c.getPrinterAttributes(p).get('natural-language-configured')
> EOF
> 
> What output do you get?

Output is en_US

Also in reply to #6
> Somewhere you have LC_ALL=POSIX, which isn't what you want.

You are quite right.  This will have to change.  How should LC_<Whatever> be set?
Comment 11 Tim Waugh 2009-10-22 11:49:48 EDT
Well, I'm not sure where you've set it. :-)

A fresh installation just sets LANG, and the locale is keyed off that.  It is set in /etc/sysconfig/i18n.

So, the remaining issue is:

4. The lj4dith and ljet4 drivers give incorrect output for this printer.

As the gutenprint driver is higher quality and actually maintained, and is now working correctly, I don't really think it's worth spending any time on fixing these old ghostscript built-in drivers.

Closing...

Note You need to log in before you can comment on or make changes to this bug.