Bug 513943 - PATCH: check for OROM firmware information in 512 bytes increments on PCI-3.x systems
PATCH: check for OROM firmware information in 512 bytes increments on PCI-3.x...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mdadm (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Doug Ledford
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-27 04:12 EDT by Hans de Goede
Modified: 2009-09-15 15:26 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-15 15:26:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
PATCH: check for OROM firmware information in 512 bytes increments on PCI-3.x systems (2.61 KB, patch)
2009-07-27 04:12 EDT, Hans de Goede
no flags Details | Diff

  None (edit)
Description Hans de Goede 2009-07-27 04:12:26 EDT
Created attachment 355245 [details]
PATCH: check for OROM firmware information in 512 bytes increments on PCI-3.x systems

Hi Doug,

The current mdadm fails to find the OROM of my Intel BIOS RAID test system,
because it is aligned at a multiple of 512 bytes (which is allowed for
PCI 3.x systewms) but mdadm only checks for 2048 bytes aligned ROM headers.

The attached patch is a modified (fixed to ignore . and .. dir entries) version
of a patch for this by Dan Williams which is on its way to upstream. Can you
please add this patch to the Fedora mdadm package, as it is needed for correct
operation of Intel BIOS RAID on systems where the OROM start is not aligned
to 2048 bytes.

Alternatively if ok with you I can make the necessary changes to the specfile and commit and build a new version myself.
Comment 1 Doug Ledford 2009-07-27 09:44:10 EDT
I have some additional changes I wish to make, so I'll push an updated mdadm (probably get it built sometime today and push shortly after).
Comment 2 Doug Ledford 2009-09-15 15:05:23 EDT
This is fixed in the latest upstream mdadm git repo, which is being used in the current build.

Note You need to log in before you can comment on or make changes to this bug.