Bug 51407 - Ethernet fails after APM resume on Dell Inspiron 8000 (A12 BIOS)
Ethernet fails after APM resume on Dell Inspiron 8000 (A12 BIOS)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
i386 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-10 05:59 EDT by David Woodhouse
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-16 06:38:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Nicer trigger for forcing the config space restore (1.91 KB, patch)
2001-08-17 08:35 EDT, David Woodhouse
no flags Details | Diff

  None (edit)
Description David Woodhouse 2001-08-10 05:59:24 EDT
Description of Problem:

On the Dell Inspiron 8000 laptop, PCI config space for the PCI bridges and
eepro100 are lost after an APM suspend. Noting the contents of the config
space before suspend and restoring the appropriate parts (BARs, command
reg, latency regs etc.) after resume fixes the problem.

PCI drivers should probably each have a pair of suspend/resume methods
which save and restore the useful registers.
Comment 1 Arjan van de Ven 2001-08-10 11:26:49 EDT
Can be fixed trivially
Comment 2 Glen Foster 2001-08-10 15:59:20 EDT
We (Red Hat) should really fix this before next release.
Comment 3 Arjan van de Ven 2001-08-10 16:31:22 EDT
Fixed in 2.4.7-0.13.1
Comment 4 David Woodhouse 2001-08-16 06:38:45 EDT
Now APM suspend works, but only after we've successfully done a suspend-to-disk. 

The kernel seems to be unconditionally enabling the local APIC, even when
'noapic' is passed on the command line. The command line parsing and DMI scan
are done after the local APIC is set up. 

Disabling CONFIG_X86_UP_IOAPIC fixes this. The BIOS was evidently failing to
deal correctly with the local apic. The kernel's suspend/resume methods for the
local apic weren't being registered, because that part of the setup _was_
prevented by the lack of 'apic' on the command line.
Comment 5 Arjan van de Ven 2001-08-17 08:22:13 EDT
Worked around in 2.4.7-2.4, real fix pending
Comment 6 David Woodhouse 2001-08-17 08:35:27 EDT
Created attachment 28273 [details]
Nicer trigger for forcing the config space restore

Note You need to log in before you can comment on or make changes to this bug.