Bug 514528 - Xvnc segfaults when running gimp
Xvnc segfaults when running gimp
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tigervnc (Show other bugs)
11
All Linux
low Severity high
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-29 10:40 EDT by Jón Fairbairn
Modified: 2013-04-30 19:44 EDT (History)
3 users (show)

See Also:
Fixed In Version: 0.0.91-0.12.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-28 17:55:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jón Fairbairn 2009-07-29 10:40:11 EDT
Description of problem:
Attempting to use the "pencil" tool of gimp causes Xvnc to segfault

Version-Release number of selected component (if applicable):
tigervnc-server-0.0.91-0.11.fc11.x86_64
(gimp-2.6.6-6.fc11.x86_64)

How reproducible:
100% (twice out of two attempts).

Steps to Reproduce:
1. Start vnc server (mine is started from /etc/init.d/vncserver)
2. connect to the vnc session 
3. start gimp on some jpeg image
4. select the pencil tool
5. click on the image
  
Actual results:
Vnc session disappears;
Jul 29 12:01:02 calligramme kernel: Xvnc[3094]: segfault at 0 ip (null) sp 00007fff9bc36f68 error 14 in Xvnc (deleted)[400000+217000]
in syslog

Expected results:
A dot on the image.

Additional info:
from /etc/sysconfig/vncservers
VNCSERVERS="1:jf"
VNCSERVERARGS[1]="-geometry 1024x768 -depth 24 -nolisten tcp -localhost"
Comment 1 Jón Fairbairn 2009-08-06 05:10:13 EDT
Same thing happens if I try to run inkscape on a vnc server

inkscape-0.47-0.8.20090508svn.fc11.x86_64

Start Xvnc; start inkscape; select the text tool; click on the canvas.

segfault happens whether or not Xvnc is started from an ssh session.

This is very annoying!
Comment 2 Fedora Update System 2009-08-14 10:14:50 EDT
tigervnc-0.0.91-0.12.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/tigervnc-0.0.91-0.12.fc11
Comment 3 Fedora Update System 2009-08-15 04:12:59 EDT
tigervnc-0.0.91-0.12.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update tigervnc'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8553
Comment 4 Fedora Update System 2009-08-28 17:55:36 EDT
tigervnc-0.0.91-0.12.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 feddy 2010-10-31 04:12:52 EDT
Hitting an identical problem building both 1.0.0 and 1.0.1 for kubuntu 9.04 , in case that is any help.

I start vncserver from client machine by ssh link.

starting vncserver :1 as either root or user produces the same result. Some gimp funstions such as renaming/saving files is fine but as soon as I click on a image canvas in gimp I get the same error in dmesg.

[49747.835746] Xvnc[15186]: segfault at 0 ip 0000000000000000 sp 00007fff9827bfb8 error 14 in Xvnc[400000+237000]

doing the same operation on :0 I get similar but not identical result:

[50562.573784] Xorg[5782]: segfault at 20 ip 0000000000496786 sp 00007fff3b57ba60 error 4 in Xorg[400000+1c3000]
[50562.712616] [drm:gm45_get_vblank_counter] *ERROR* trying to get vblank count for disabled pipe 0
[50566.065777] [drm:i915_setparam] *ERROR* unknown parameter 4

I think the last 2 lines are part of X:0 being restarted by gdm.
 

Other vnc usages seems fast and stable. Very impressive.
Comment 6 Adam Tkac 2010-11-02 06:25:42 EDT
(In reply to comment #5)
> Hitting an identical problem building both 1.0.0 and 1.0.1 for kubuntu 9.04 ,
> in case that is any help.
> 
> I start vncserver from client machine by ssh link.
> 
> starting vncserver :1 as either root or user produces the same result. Some
> gimp funstions such as renaming/saving files is fine but as soon as I click on
> a image canvas in gimp I get the same error in dmesg.
> 
> [49747.835746] Xvnc[15186]: segfault at 0 ip 0000000000000000 sp
> 00007fff9827bfb8 error 14 in Xvnc[400000+237000]
> 
> doing the same operation on :0 I get similar but not identical result:
> 
> [50562.573784] Xorg[5782]: segfault at 20 ip 0000000000496786 sp
> 00007fff3b57ba60 error 4 in Xorg[400000+1c3000]
> [50562.712616] [drm:gm45_get_vblank_counter] *ERROR* trying to get vblank count
> for disabled pipe 0
> [50566.065777] [drm:i915_setparam] *ERROR* unknown parameter 4
> 
> I think the last 2 lines are part of X:0 being restarted by gdm.
> 
> 
> Other vnc usages seems fast and stable. Very impressive.

Please report this issue against X.Org in the Ubuntu bug tracker. Xvnc is based on the X.Org source and if gimp crashes X server then it must be fixed before Xvnc.
Comment 7 feddy 2010-11-02 08:36:08 EDT
Gimp does not crash xserver on it's own. If I remove tigervnc, gimp and inkscape function correctly. 

That was not said explicitly but seems to be implied by OP as well.

This would seem to show that it is the vnc module that is causing the crash not gimp ( or possibly gtk+ that is the most obvious common lib for inkscape and gimp.)

Since ubuntu do not package tigervnc I see no justification for posting this to lauchpad. The distro packages work normally.
Comment 8 Jón Fairbairn 2010-11-02 09:59:08 EDT
unning gimp or inkscape to an Xvnc server from tigervnc-server-1.0.1-3.fc12.x86_64
works fine, so this bug is not present in Fedora 12, at least. So either you don't have the same bug as I originally reported, or your build doesn't include the relevant patch, or the bug has crept back in.
Comment 9 feddy 2010-11-05 05:44:28 EDT
Adam Tkac: 
" Please report this issue against X.Org in the Ubuntu bug tracker. Xvnc is based
on the X.Org source and if gimp crashes X server then it must be fixed before
Xvnc."

Adam, I find it hard to justify submitting a bug based on what I have:

I build tigervnc vncserver on Ubuntu 9.04 and it works.
I download ubuntu source for xorg, I patch it with non ubuntu xserve16.patch. 
I build and install Xvnc, vncsaerver et al.
I restart the machine and now vncserver crashes X. 

I would expect that to get pretty short shrift as a bug report.

You are obviously a lot more familiar with the software and ensueing build problems than I am. Were you just going form what I reported here or are you aware of specific issue on Ubuntu xorg 1.6 ?

It would seem I need something more concrete than what I have to lay this on Ubuntu.

Note You need to log in before you can comment on or make changes to this bug.