Bug 51459 - boot Failed on Compaq
boot Failed on Compaq
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-10 13:06 EDT by infinet
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-13 11:38:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description infinet 2001-08-10 13:06:26 EDT
Description of Problem:
I am trying to Load Red Hat Linux 7.1 on a Compaq 5BW160 and everytime I 
get a boot failure. I have tried boot disks from red Hat 5.2 and 7.1 and I 
recieve the same problem. When I used the Slackware Installation disk I 
got all the way till it asked for a root disk that I had not made. 

How Reproducible:
Always 

Steps to Reproduce:
1. Insert Boot disk 
2. get the  first setup screeen 
3.  hit enter 

Actual Results:
Boot Failed

Expected Results:
for the installation to continue

Additional Information:
	
I know Compaq has a horrible record with Red Hat Linux, But I would liek 
to try to install it. My biggets prolem is I don't get a error log file 
or a verbose setting to find out where the Installation is Failing.
Comment 1 Brent Fox 2001-08-10 13:11:45 EDT
What does the screen say when the boot fails?  Also, make sure that you are not
mixing boot disks with different versions.  Only use 7.1 boot floppies with 7.1.
 Otherwise, you will see strange behavior.
Comment 2 infinet 2001-08-10 15:32:54 EDT
I don't know Right off the bat I get boot failure after i get the initial 
screen and hit enter.
Comment 3 Brent Fox 2001-08-10 16:16:18 EDT
What steps did you take to create the boot disks?
Comment 4 infinet 2001-08-10 18:10:03 EDT
i downloaded rawrite and two images boot.img and bootnet.img. I made both on 
seperate disks. I have been taking to the creator or maintainer or syslinux and 
I have updated or have the new syslinux 1.63. I have managed to have it load 
the init....img and try to load the Kernel vmlinuz but it all  of a sudden 
reboots after it finishes loading the kernel.
Comment 5 Brent Fox 2001-08-13 11:38:24 EDT
It sounds like you could be having hardware troubles.  I can't think of any
other reason for the behavior that you are seeing.  If the kernel isn't even
getting properly loaded, the Red Hat installer isn't even getting a chance to
run.  I'm really suspicious of the hardware if the bootdisks from 5.2 *and* 7.1
don't work.

Red Hat Linux 7.1 works well with the Compaqs that we have in the test lab,
which is pretty much the entire ProLiant line of servers.  It works fine on the
iPaq desktop and on my Presario 1700T laptop.  So I'd be very surprised if it
didn't work on yours too, although I'm not familiar with the 5BW160.  Can you
provide more information about the type of hardware in the machine?
Comment 6 Brent Fox 2001-08-23 11:11:07 EDT
Closing due to inactivity.  Please reopen if you have more information.
Comment 7 Need Real Name 2002-05-30 16:45:06 EDT
Hi, I have a similar problem with RHL 7.1 on a Compaq Presario 7470 Desktop. 
Can start from the /boot directory on the hard disk, but cannot boot from 
floppy. The error is "Boot Failed: Please change disks and continue". Have 
attempted with multiple floppy disks, including non-generic (IBM brand, to be 
specific). Have tried both the mkbootdisk command and the dd command (with 
if=boot.img or something like that).

BTW this is a demo version of 7.1 that came free with the book "Mastering RHL 
7.1". NOW, RHL 7.0 installed earlier on this machine from the boxed set had no 
problems creating the boot disk. COULD IT BE this demo version (only 1 cd) has 
a somewhat deficient kernel? 

(I have just recently downloaded the 2.4.2-2 kernel rpm and plan to install it, 
uh - if that could make any difference ?? ;D )

any clues? please e-mail SHAYGYI@msn.com Thanks in advance...
Comment 8 Brent Fox 2002-05-30 16:56:00 EDT
shaygyi, as far as I know, 7.1 was a two cd set.  It's entirely possible that
the publisher of the book you bought modified 7.1 by removing packages so that
it would fit onto one cd.  Calling it "Red Hat Linux" at that point is pretty
misleading.  As such, I have no way of knowing what kind of modifications were
made or if they would cause the behavior you are seeing.  

If you have a fast internet connection, I'd suggest downloading Red Hat Linux
7.3, which is our latest version.  There have been many improvements since 7.1.
 It can be found at: 
ftp://ftp.redhat.com/pub/redhat/linux/7.3/en/iso/i386/

If you still have problems with the latest release, please open a new bug report
against 7.3.  Thanks for your post.
Comment 9 Need Real Name 2002-06-05 12:56:28 EDT
thanks bfox:
no, I don't have a fast connection, just 56.6K.
However, I do have the 2.4.7-10 kernel rpm (plus headers, etc) 
that was part of RHL 7.2. So I did all the recommended
rpm -Uvh / -Ivh install commands (as per 
http://www.redhat.com/support/resources/howto/kernel-upgrade/s1-upgrade.html)
. Upgrade was successful,however still can't create a boot floppy that works. 
Am now focusing on how to create a boot cd... :D
Comment 10 Need Real Name 2002-06-20 12:58:28 EDT
TO follow up...
have now received the 3-cd RHL 7.3 set from linuxcentral.com...
Custom Install successful. New, Improved KDE & Gnome both look sharp.

Took the boot disk created in the install process and attempted boot - FAILED!
Reformatted (with kfloppy) to ext2 file system (was MSDOS?) and built boot disk 
with mkbootdisk. Attempted boot - FAILED!
 
A rhetorical question: Is some rare combination of Compaq, LILO, and (what?: 
kernel size??) causing this?? 

Note You need to log in before you can comment on or make changes to this bug.