Bug 51465 - Kernel oops / segfault when running programs
Kernel oops / segfault when running programs
Status: CLOSED CURRENTRELEASE
Product: Red Hat Public Beta
Classification: Retired
Component: kernel (Show other bugs)
roswell
i686 Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
: 51466 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-10 14:11 EDT by Matt Biermann
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-19 09:49:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
requested dmesg output (8.43 KB, text/plain)
2001-08-10 15:46 EDT, Matt Biermann
no flags Details

  None (edit)
Description Matt Biermann 2001-08-10 14:11:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.78 [en] (X11; U; Linux 2.4.6-3.1 i686)

Description of problem:
After using 7.1.93 for twenty minutes or so, random segfaults will start to
occur.  Anything from bash, to "w", to ls, anything at all.  In second VT,
kernel oops around the same time would pop up.  I am unable to reproduce
it, but it's happenedtwice now since upgrading 3 hours ago.

How reproducible:
Didn't try


Additional info:

oops message when running up2date-nox from console

 kernel BUG at page_alloc.c:240!
invalid operand: 0000
CPU:    0
EIP:    0010:[<c0130db8>]
EFLAGS: 00010086
eax: 00000020   ebx: c106fc50   ecx: 00000001   edx: 00002888
esi: c026f044   edi: c106fc50   ebp: 00000002   esp: c5e9be3c
ds: 0018   es: 0018   ss: 0018
Process up2date-nox (pid: 1100, stackpage=c5e9b000)
Stack: c022512d 000000f0 00000994 00000212 c026eebc 00000000 c026ee60
c026ee60
       c026f044 00000000 000000d2 c01310be 00000001 000000d2 00104025
00000000
       c1004520 c01312bf 000000d2 00000000 c026f040 415bf000 00104025
00000001
Call Trace: [<c022512d>] [<c01310be>] [<c01312bf>] [<c0125cf2>]
[<c01265fe>]
   [<c014a5ba>] [<c0115a80>] [<c0115bfa>] [<c0126b9e>] [<c0129220>]
[<c010b916>]
   [<c011c7db>] [<c0115a80>] [<c0106fe8>]
 
Code: 0f 0b 5e 58 8b 07 89 de 8b 57 04 89 50 04 89 02 8b 44 24 10
Comment 1 Matt Biermann 2001-08-10 14:16:11 EDT
  Aug 10 14:10:48 rival kernel:  kernel BUG at page_alloc.c:240!
Aug 10 14:10:48 rival kernel: invalid operand: 0000
Aug 10 14:10:48 rival kernel: CPU:    0
Aug 10 14:10:48 rival kernel: EIP:    0010:[rmqueue+248/736]
Aug 10 14:10:48 rival kernel: EIP:    0010:[<c0130db8>]
Aug 10 14:10:48 rival kernel: EFLAGS: 00010086
Aug 10 14:10:48 rival kernel: eax: 00000020   ebx: c106fc50   ecx: 00000001  
edx: 000047eb
Aug 10 14:10:48 rival kernel: esi: c026f024   edi: c106fc50   ebp: 00000002  
esp: c1997ef0
Aug 10 14:10:48 rival kernel: ds: 0018   es: 0018   ss: 0018
Aug 10 14:10:48 rival kernel: Process bash (pid: 1307, stackpage=c1997000)
Aug 10 14:10:48 rival kernel: Stack: c022512d 000000f0 ce257009 00000212
c026eebc 00000001 c026ee60 c026ee60
Aug 10 14:10:48 rival kernel:        c026f024 00000001 000000f0 c01310be
00000000 000000f0 bfffefc0 00000001
Aug 10 14:10:48 rival kernel:        c1996000 c01312bf 000000f0 00000001
c026f020 c1996000 bfffefc0 00000000
Aug 10 14:10:48 rival kernel: Call Trace: [copyrite+19661/36724]
[_wrapped_alloc_pages+110/608] [__alloc_pages+15/160] [__get_free_pages+16/32]
[do_fork+144/1744]
Aug 10 14:10:48 rival kernel: Call Trace: [<c022512d>] [<c01310be>] [<c01312bf>]
[<c0131360>] [<c0117dc0>]
Aug 10 14:10:48 rival kernel:    [path_release+16/48] [sys_stat64+100/112]
[sys_fork+21/32] [system_call+51/56]
Aug 10 14:10:48 rival kernel:    [<c0141820>] [<c013f4b4>] [<c0105a95>]
[<c0106eeb>]
Aug 10 14:10:48 rival su(pam_unix)[1305]: session closed for user root
Aug 10 14:10:48 rival kernel:
Aug 10 14:10:48 rival kernel: Code: 0f 0b 5e 58 8b 07 89 de 8b 57 04 89 50 04 89
02 8b 44 24 10
Comment 2 Matt Biermann 2001-08-10 15:00:46 EDT
*** Bug 51466 has been marked as a duplicate of this bug. ***
Comment 3 Arjan van de Ven 2001-08-10 15:18:40 EDT
Are you running anything special, such as nvidia modules ?
Comment 4 Arjan van de Ven 2001-08-10 15:19:42 EDT
Also, is this a IBM machine ?
Comment 5 Matt Biermann 2001-08-10 15:27:25 EDT
It's a PC clone Soyo 6BB motherboard BX chipset, P3 500 w/ 384 megs ram.  Video
is a Matrox G400 dual head with 32Meg ram running in single head mode.  2930CU
SCSI card with a plextor CD-r, tosh CD, and a Sony DDS4 tape.

Nothing really special or out of the ordinary in any way and RH 7.1 ran
beautifully.
Comment 6 Arjan van de Ven 2001-08-10 15:44:42 EDT
Would you mind attaching (via the "create a new attachement" thing) the output
of "dmesg" to this bug ?
Comment 7 Matt Biermann 2001-08-10 15:46:17 EDT
Created attachment 27315 [details]
requested dmesg output
Comment 8 Glen Foster 2001-08-10 15:59:15 EDT
We (Red Hat) should really fix this before next release.
Comment 9 Arjan van de Ven 2001-08-17 08:23:14 EDT
Hi,
Could you try the 2.4.7-2 kernel that is now in rawhide?
We fixed several things, and at least one of those could explain what you
were seeing.

Note You need to log in before you can comment on or make changes to this bug.