Bug 51481 - Compiling iptables-1.2.2-3 produce perl errors
Compiling iptables-1.2.2-3 produce perl errors
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: iptables (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-10 16:35 EDT by Oliver Schulze L.
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-12 15:51:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oliver Schulze L. 2001-08-10 16:35:11 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.2)
Gecko/20010726 Netscape6/6.1

Description of problem:
doing a rpm --rebuild iptables-1.2.2-3.src.rpm
generate the rpm corectly, but prints this errors when compiling it:
Can't do inplace edit: extensions is not a regular file, <> line 339.
Can't do inplace edit: include is not a regular file, <> line 339.
Can't do inplace edit: ippool is not a regular file, <> line 6170.
Can't do inplace edit: libipq is not a regular file, <> line 13919.
Can't do inplace edit: libiptc is not a regular file, <> line 13919.
Can't do inplace edit: libipulog is not a regular file, <> line 13919.
Can't do inplace edit: patch-o-matic is not a regular file, <> line 14277.
Can't do inplace edit: include/libippool is not a regular file, <> line 26392.
Can't do inplace edit: include/libipq is not a regular file, <> line 26392.
Can't do inplace edit: include/libiptc is not a regular file, <> line 26392.
Can't do inplace edit: include/libipulog is not a regular file, <> line 26392.
Can't do inplace edit: include/linux is not a regular file, <> line 26392.
Can't do inplace edit: patch-o-matic/ac-series is not a regular file, <>
line 37029.
+ exit 0

this is the line before:
Patch #1 (iptables-1.2.2-cvsfixes.patch):
+ patch -p1 -b --suffix .cvs -s
+ perl -pi -e s,/usr/local,/usr,g COPYING extensions include INSTALL
ip6tables.c


How reproducible:
Always

Steps to Reproduce:
1. In RH7.1 do:
2. rpm --rebuild iptables-1.2.2-3.src.rpm
3.
	

Additional info:
Comment 1 Oliver Schulze L. 2001-08-12 15:50:58 EDT
Also, after that, I get some 'permision denied':
Can't do inplace edit: patch-o-matic/ac-series is not a regular file, <> line 37029.
+ exit 0
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.62133
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd iptables-1.2.2
+ OPT=-O2 -march=i386 -mcpu=i686
+ make 'COPT_FLAGS=-O2 -march=i386 -mcpu=i686' LIBDIR=/lib
/bin/sh: extensions/.mport-test: Permission denied
Making dependencies: please wait...
/bin/sh: extensions/.mport-test: Permission denied
Extensions found: IPv6:owner IPv6:limit IPv6:mac IPv6:multiport
cc -O2 -march=i386 -mcpu=i686 -Wall -Wunused -I/usr/src/linux/include -Iinclude/
-DNETFILTER_VERSION=\"1.2.2\"  -fPIC -o extensions/libipt_tcp_sh.o -c
extensions/libipt_tcp.c

HTH
Comment 2 Bernhard Rosenkraenzer 2001-08-20 07:31:15 EDT
Don't worry about them.
The perl errors are generated by a quick-and-dirty script to replace all 
references to /usr/local with /usr - and of course the sed call won't work 
when it hits a directory.

The permission denied "bug" is intentional as well: we don't want the checks 
to be run because we don't want the build process to make assumptions based on 
our build machines.
Comment 3 Oliver Schulze L. 2001-08-20 09:58:17 EDT
Thanks for the detailled explanation.

Note You need to log in before you can comment on or make changes to this bug.