Bug 51494 - Power Managment or ACPI shutdown locks pc after ~20 mins of use
Power Managment or ACPI shutdown locks pc after ~20 mins of use
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: kernel (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-10 19:46 EDT by Byron Miller
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-17 10:40:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Byron Miller 2001-08-10 19:46:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2)
Gecko/20010726 Netscape6/6.1

Description of problem:
When using roswell on a DELL C600 i come across a problem that after
resuming from an apm monitor shutdown within a few minutes the whole pc
freezes and i have to hard shutdown.  By default the 2.4.6 kernel doesn't
recognize the acpi system on this laptop so it defaults to apm for
powermanagement (which is also enabled under kde to monitor battery juice)

I manually compiled 2.4.7 with ACPI and ACPI management so apm doesn't load
and i don't have this problem anymore. (kernel module, bug in 2.4.6 or??)

is there a later kernel i can load from redhat or just stick with my custom
one?

How reproducible:
Always

Steps to Reproduce:
1.boot into xfree86
2.let apm shutdown monitor
3.use for a few minutes,
4. letp apm kick in
5. pc freezes
	

Actual Results:  lockup - looks like verything is normnal, but no response
from keyboard, mouse or pointing devices (touchpad, usb mouse and keyboard)

Expected Results:  resume from apm

Additional info:

dell c600
p3 1000mhz
256 megs ram
Comment 1 Glen Foster 2001-08-13 15:07:59 EDT
We (Red Hat) should really try to fix this before next release.
Comment 2 Arjan van de Ven 2001-08-17 05:49:57 EDT
I've been working on resume problems on a Dell inspiron 8000 recently (a
coworker has one) and fixed several things in the resume code in the kernel.
Once kernel 2.4.7-2.4 or later enters Rawhide, could you try with that ?
Comment 3 Byron Miller 2001-08-17 10:37:28 EDT
I am downloading rawhide right now. I will give it a shot and keep both releases
on my laptop to see how it works.

One question, with the new ACPI power management features in 2.4.7 or higher
kernels should i even bothere with APMD?  It looks like the new ACPI stuff works
with the cpu temp, monitor disable, spin down, spin up and all that good stuff
Comment 4 Byron Miller 2001-08-17 10:37:33 EDT
I am downloading rawhide right now. I will give it a shot and keep both releases
on my laptop to see how it works.

One question, with the new ACPI power management features in 2.4.7 or higher
kernels should i even bothere with APMD?  It looks like the new ACPI stuff works
with the cpu temp, monitor disable, spin down, spin up and all that good stuff
Comment 5 Arjan van de Ven 2001-08-17 10:39:29 EDT
ACPI is currently disabled, and will be for quite some time. The reason for that
is that ACPI executes bios code in kernelmode (and lots of it) and most bioses
have SO many bugs in it that it's unworkable.
Comment 6 Arjan van de Ven 2001-08-17 10:40:22 EDT
Oh and I'm not sure -2.4 is in rawhide yet; iirc -2.0 is in there; rawhide is
only updated once a week or so and I fixed this yesterday

Note You need to log in before you can comment on or make changes to this bug.