Bug 51501 - /var/lib/dhcp/dhcpd.leases does not exist
Summary: /var/lib/dhcp/dhcpd.leases does not exist
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: dhcp
Version: roswell
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Elliot Lee
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-08-11 02:23 UTC by adler
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2001-12-10 18:59:49 UTC


Attachments (Terms of Use)
dhcpd control script: attempt to fix common problems with /var/lib/dhcp/dhcpd.leases (399 bytes, patch)
2001-12-10 19:07 UTC, Jim Meyer
no flags Details | Diff

Description adler 2001-08-11 02:23:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.2) Gecko/20010725

Description of problem:
The file /var/lib/dhcp/dhcpd.leases does not exist and must be created by
hand. The file /var/lib/dhcp/dhcp.leases does exist. Thus this looks like a
typo problem.

How reproducible:
Always

Steps to Reproduce:
1.Install roswell
2.execute the command 'dhcpd'
3.
	

Additional info:

Comment 1 Glen Foster 2001-08-13 19:07:03 UTC
We (Red Hat) should really try to fix this before next release.

Comment 2 Keith Hudson 2001-08-18 16:51:39 UTC
To fix the rpm You need to replace the instances of dhcp.leases with 
dhcpd.leases in the dhcp.spec file then build a new rpm. The current one 
touches dhcp.leases instead of dhcpd.leases

Comment 3 Jim Meyer 2001-12-10 18:59:45 UTC
This is also a problem in RH7.1; a backpatch would be appreciated.

Comment 4 Elliot Lee 2001-12-10 19:03:05 UTC
This is fixed in 7.2 - you shouldn't have any problems grabbing the
dhcp-2.0pl5-8 from there and installing it on a 7.1 system.

Comment 5 Jim Meyer 2001-12-10 19:07:09 UTC
Created attachment 40308 [details]
dhcpd control script: attempt to fix common problems with /var/lib/dhcp/dhcpd.leases


Note You need to log in before you can comment on or make changes to this bug.