Bug 51522 - switchdesk does not allow me to switch back to Sawfish
switchdesk does not allow me to switch back to Sawfish
Product: Red Hat Public Beta
Classification: Retired
Component: XFree86 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
Depends On:
  Show dependency treegraph
Reported: 2001-08-11 13:41 EDT by teuben
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-08-12 22:18:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description teuben 2001-08-11 13:41:54 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010801

Description of problem:
My roswell system has become completely useless. It might very well
be the kernel, the VM in 2.4.6 seems to be pretty bad. Basically
overnight, after updatedb has run, and disk I/O buffers have 'polluted'
memory, linux really doesn't want to give it,resulting in overmassive
I/O and incredible slow performance. My P600 laptop has 256M with
512M swap, and it behaves like a 486/100 or worse.

First I thought it was sawmill + nautilus, so i switched back to
enlightenment. There the menus were all corrupted and not present
I should see (e.g. no panel , no desktop icons).So after i figured
out the VM problem was not sawfish, wanted to go back to Sawfish.

switchdesk itself (the cmdline utility) didn't want to let me choose
sawfish (tried various spellings), so tried the gnome version,that
one caused X to terminate back to console....

I'm sorry, i hope the final version will be better, I've spent a lot
of time this week on this beta, making it my daily machine, but it
has become totally useless, and I will switch back to rh62 or 71...

How reproducible:

Steps to Reproduce:
2.select Sawfish, while Enlightnement is active
3.X terminates

Additional info:
Comment 1 teuben 2001-08-11 21:50:30 EDT
so, ok, i'm a whimp, i switched back to redhat 7.1, but also learned another
thing about this bug:

The same problem is present on rh71 !!!!  

In fact, it's partially a pilot error due to not thinking of the difference
between window manager and desktop manager?   The bug still remains i believe,
if you switch to sawfish, X dies. However, i found if it did
	switchdesk GNOME
on the console, and started X, it was happily back in sawfish.
I will now patiently await the nightly crontab to see if memory becomes
locked up again. Although this is kernel 2.4.2 (i didn't upgrade that part
of rh71 yet).
So far however, rh71 has been a blessing. Knock on wood of course.
Comment 2 Bernhard Rosenkraenzer 2001-08-12 07:09:20 EDT
switchdesk isn't supposed to let you use plain sawfish.

Switchdesk supports:

GNOME (this uses sawfish)

switchdesk doesn't do anything that could cause an X server crash (actually it 
just changes your .Xclients file), so if X is crashing when switchdesk is 
running, you're either facing an X problem or a problem with your X session 
(e.g. when you're in enlightenment, your .Xclients file does "exec 
/usr/bin/enlightenment", so if enlightenment crashes, your X session will 

Can't reproduce it here; assigning to XFree86 because it's a possible source 
of the problem.

Please provide more info (e.g. which X driver are you using, do you see any 
messages when X exits, ...)

Comment 3 teuben 2001-08-12 10:12:32 EDT
I created a new clean account, and could not reproduce it either, so after
your info i conclude (despite that I thought I had cleaned up everything)
that I forgot one of the .Xclients and for some reason it wound up with the
wrong contents.

I would also like to report that redhat7.1 survived the night beautifully,
it's like day and night (no pun intended) difference. The beta just didn't
work for me. I still suspect it's the kernel, the rh71 kernel is after
a little earlier and I did hear some trouble about VM, but I never would have
thought my P600/256M would behave like a 486 with 32M....  I still wonder why
nobody at redhat noticed this behavior. Is nobody using their beta machines
with a fair number of windows open and letting it run overnight?
Comment 4 Bernhard Rosenkraenzer 2001-08-12 11:41:26 EDT
We do; this doesn't happen on every machine though. (and most of us are 
running a much more recent kernel by now - the post-beta1 changes need testing 
(check out rawhide).
Comment 5 teuben 2001-08-12 22:18:20 EDT
I should also add another laptop difference between rh71 and roswell!
Roswell runs a newer version, 4.1, whereas rh71 runs 4.0.3. Like on rh62
on this laptop (where i ran a patched 3.3.6) coming out of suspend my
X display would be ready for use in about 10-15 seconds. 

Under whistler this was about 40-50 seconds!!!!!    I don't know if
this is a redhat problem, but I would like to hear if other redhat
laptop users have experienced this. 10-15 secs i find ok,  but the
40-50 sec wait is very very long. I might as well do suspend to disk,
or just reboot for that matter.

Note You need to log in before you can comment on or make changes to this bug.