Bug 515794 - A screensaver crashes Gnome and XFCE sessions
A screensaver crashes Gnome and XFCE sessions
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: jmccann
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-05 14:37 EDT by Horst H. von Brand
Modified: 2015-01-14 18:23 EST (History)
4 users (show)

See Also:
Fixed In Version: gnome-screensaver-2.27.0-3.fc12.x86_64
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-10 14:59:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Horst H. von Brand 2009-08-05 14:37:54 EDT
Description of problem:
When leaving the screensaver running, leaving the machine alone for a while gets me logged out. 

Version-Release number of selected component (if applicable):
xscreensaver-5.08-12.fc12.x86_64
xscreensaver-extras-5.08-12.fc12.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Leave ;-)
2.
3.
  
Actual results:
Session crash

Expected results:
Screensaver...

Additional info:
I've seen some screensavers starting OK, but after a short while (random selection, most are active) my session gets killed.
Comment 1 Mamoru TASAKA 2009-08-06 14:00:23 EDT
Well, would you attach the results of the following?

- the result of $ rpm -qa | grep screensaver | sort
- the output of $ xscreensaver -verbose -sync (once after you kill
  xscreensaver by $ xscreensaver-command -exit)
- /etc/X11/xorg.conf
- /var/log/Xorg.0.log (or maybe /var/log/Xorg.0.log.old)
Comment 2 Horst H. von Brand 2009-08-10 11:44:16 EDT
This is after lots of updates in X since my report. No xorg.conf (hasn't been for a long time).

  $ rpm -qa | grep screensaver | sort
  fedorainfinity-screensaver-theme-1.0.0-3.fc12.noarch
  fedora-screensaver-theme-1.0.0-5.fc12.noarch
  gnome-screensaver-2.27.0-3.fc12.x86_64
  xscreensaver-5.08-12.fc12.x86_64
  xscreensaver-base-5.08-12.fc12.x86_64
  xscreensaver-extras-5.08-12.fc12.x86_64
  xscreensaver-extras-gss-5.08-12.fc12.x86_64
  xscreensaver-gl-base-5.08-12.fc12.x86_64
  xscreensaver-gl-extras-5.08-12.fc12.x86_64
  xscreensaver-gl-extras-gss-5.08-12.fc12.x86_64

  $ xscreensaver-command -exit
  xscreensaver-command: no response to command.

It seems that with my current setup it just didn't start?! I distinctly remember seeing a screensaver starting yesterday (only change since then was update of xorg-x11-drv-nouveau-0.0.15-2.20090805git712064e.fc12.x86_64, irrelevant in my case). Started the screensaver, will send this off and report later if it crashes again (+ requested outputs).
Comment 3 Mamoru TASAKA 2009-08-10 12:11:54 EDT
Thank you. Actually you are using gnome-screensaver, not xscreensaver.
Comment 4 Horst H. von Brand 2009-08-10 14:59:34 EDT
That would then be gnome-screensaver-2.27.0-3.fc12.x86_64.

After starting the screensaver as directed, I left the machine alone over lunch (and then some), it works fine now (screen was being saved when I came back, and I got back to my session without a hitch).

There were other problems that just "went away" recently (due to Gnome, X updates?). Closing this one.

Sorry for wasting your time.

Note You need to log in before you can comment on or make changes to this bug.