Bug 515870 - Error message about missing module uprobes when updating package systemtap
Error message about missing module uprobes when updating package systemtap
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: systemtap (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Frank Ch. Eigler
Fedora Extras Quality Assurance
:
: 516166 518015 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-06 02:44 EDT by Joachim Frieben
Modified: 2009-08-18 17:15 EDT (History)
8 users (show)

See Also:
Fixed In Version: 0.9.9-3.fc11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-18 17:11:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2009-08-06 02:44:36 EDT
Description of problem:
When updating package systemtap on a current "rawhide" system, an error message is issued:

  Updating :        systemtap-0.9.9-2.fc12.x86_64        54/115
  ERROR: Module uprobes does not exist in /proc/modules

Version-Release number of selected component (if applicable):
systemtap-0.9.9-2.fc12.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Update package systemtap.
  
Actual results:
Above error message is returned.

Expected results:
Update completes silently.

Additional info:
No module uprobes.ko is found in /lib/modules/2.6.31-0.132.rc5.git3.fc12.x86_64. However, source file are present in /usr/share/systemtap/runtime/uprobes/ and /usr/share/systemtap/runtime/uprobes2 respectively.
If module uprobes.ko is required for systemtap to work properly, then it should be provided by Fedora. Otherwise the error message should be silenced.
Comment 1 Mark Wielaard 2009-08-06 03:46:30 EDT
This is caused by this part of the spec file:

%post
# Remove any previously-built uprobes.ko materials
(make -C /usr/share/systemtap/runtime/uprobes clean) >/dev/null 3>&1 || true
(/sbin/rmmod uprobes) >/dev/null 3>&1 || true
 
%preun
# Ditto
(make -C /usr/share/systemtap/runtime/uprobes clean) >/dev/null 3>&1 || true
(/sbin/rmmod uprobes) >/dev/null 3>&1 || true

Which was introduced to fix upstream bug:
PR10182 systemtap.spec should try to clean up old leftover uprobes module.
http://sourceware.org/bugzilla/show_bug.cgi?id=10182

Obviously the '>/dev/null 3>&1' part doesn't work as intended.
What would be the correct magic incantation to make this completely silent?

Alternatively we could grep /proc/modules first before even attempting.
Comment 2 Frank Ch. Eigler 2009-08-06 06:49:52 EDT
3>&1 should probably have been 2>&1
Comment 3 Mark Wielaard 2009-08-06 11:55:44 EDT
(In reply to comment #2)
> 3>&1 should probably have been 2>&1  

ah, seems 3>&1 is just a typo. Doing 2>&1 silences the output. OK. Fixed upstream.

commit 70f2bd1fc3db8e2b555234d45e6bc3856d8afee5
Author: Mark Wielaard <mjw@redhat.com>
Date:   Thu Aug 6 17:46:27 2009 +0200

    RH515870 Error message about missing module uprobes when updating.
    
    Fix 3>&1 typo.
    
    * systemtap.spec: Use 2>&1 to redirect error messages.

Should be pulled in with the next fedora build. Then it will still give one more spurious error message on erasing the old package, but after that it is all fine.
Comment 4 Mark Wielaard 2009-08-07 03:54:57 EDT
*** Bug 516166 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2009-08-17 12:51:50 EDT
systemtap-0.9.9-3.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/systemtap-0.9.9-3.fc11
Comment 6 Fedora Update System 2009-08-17 12:51:55 EDT
systemtap-0.9.9-3.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/systemtap-0.9.9-3.fc10
Comment 7 Frank Ch. Eigler 2009-08-18 10:19:55 EDT
*** Bug 518015 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2009-08-18 17:11:48 EDT
systemtap-0.9.9-3.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2009-08-18 17:15:28 EDT
systemtap-0.9.9-3.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.