Bug 51613 - upgrade to rpm-4.0.3-0.88 problem
upgrade to rpm-4.0.3-0.88 problem
Status: CLOSED ERRATA
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-12 20:47 EDT by sean
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-12 20:47:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sean 2001-08-12 20:47:13 EDT
Description of Problem:
Upgraded rpm. Also installed db-3.2.9-4. All went well, no errors.

But now...

rpm -qa | grep db
rpmdb: Program version 3.3.11 doesn't match environment version 3.3.4
error: db3 error(22) from dbenv->open: Invalid argument
error: cannot open Packages index using db3 - Invalid argument (22)


How Reproducible:


Steps to Reproduce:
1. 
2. 
3. 

Actual Results:


Expected Results:


Additional Information:
Comment 1 Jeff Johnson 2001-08-13 10:30:29 EDT
The fix is
	rm /var/lib/rpm/__db*
which is now done in rpm-4.0.3-0.88.

Note You need to log in before you can comment on or make changes to this bug.