Bug 516338 - "A partition with the mountpoint %s has already been defined"
"A partition with the mountpoint %s has already been defined"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pykickstart (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
: Reopened
: 515063 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-08 07:14 EDT by Jeroen van Meeuwen
Modified: 2009-08-17 18:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-17 17:27:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeroen van Meeuwen 2009-08-08 07:14:00 EDT
Description of problem:

pykickstart fails over "part /" being defined twice for some of the kickstarts in the spin-kickstarts repository.

The spin-kickstarts repository has a "base.ks" on which other spins build, that sets "part / --size=3072 --fstype=ext4".

http://git.fedorahosted.org/git/?p=spin-kickstarts.git;a=blob;f=fedora-live-base.ks;h=9c4e945847c11ce33f839e41ee0c1477fae5cf6d;hb=58fc118650cb98abab8315f64224ee60d64dedb1#l17

This root filesystem size is suitable for live CDs, but is not sufficient for live DVDs.

Hence, we allow other spins to "override" the "part /" to increase the size (example: http://git.fedorahosted.org/git/?p=spin-kickstarts.git;a=blob;f=fedora-livedvd-education.ks;h=701dbb0ef011d5f1e4fc6bc69ef2974531ff12fe;hb=58fc118650cb98abab8315f64224ee60d64dedb1#l15)

Version-Release number of selected component (if applicable):

pykickstart-1.54-1.fc11.noarch

How reproducible:

Always

Steps to Reproduce:
1. git clone git://git.fedorahosted.org/spin-kickstarts.git
2. cd spin-kickstarts
3. livecd-creator -c fedora-livedvd-education.ks
  
Actual results:

Errors out on duplicate "part /" definition.

Expected results:

Take the latest it encounters and warn

Additional info:
Comment 1 Chris Lumens 2009-08-10 17:33:57 EDT
This will be fixed in the next build of pykickstart.  Thanks for the bug report.
Comment 2 Jeremy Katz 2009-08-14 10:08:13 EDT
*** Bug 515063 has been marked as a duplicate of this bug. ***
Comment 3 Jeroen van Meeuwen 2009-08-17 17:21:39 EDT
Has this fix been applied to a version in the Alpha release?
Comment 4 Chris Lumens 2009-08-17 17:27:05 EDT
This is fixed in pykickstart-1.60-1, whatever tree that's in.
Comment 5 Bruno Wolff III 2009-08-17 18:21:42 EDT
Currently pykickstart-1.60-1 is just tagged with dist-f12, so it's not in the alpha build as yet.

Note You need to log in before you can comment on or make changes to this bug.