Bug 51648 - Warning in /tmp/upgrade.log
Warning in /tmp/upgrade.log
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: anonftp (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
: 51943 52212 56950 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-13 11:41 EDT by hjl
Modified: 2007-04-18 12:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-22 06:33:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hjl 2001-08-13 11:41:55 EDT
I used glibc-2.2.4-5 to upgrade glibc in RedHat 7.1. I got

Upgrading glibc-common.
Upgrading glibc.
basename: too many arguments
Try `basename --help' for more information.
cp: cannot stat `/lib/ld-.so': No such file or directory
cp: cannot stat `/lib/libc-.so': No such file or directory
cp: cannot stat `/lib/libnsl-.so': No such file or directory
cp: cannot stat `/lib/libnss_files-.so': No such file or directory

in /tmp/upgrade.log
Comment 1 Jakub Jelinek 2001-08-13 11:47:35 EDT
This is a bug in anonftp (note to Bero, it is still there, it has not
been fixed).
The line
LIBCVER=`basename %{ROOT}/lib/libc-*.so .so | cut -f2- -d-`
is bogus, at the point of glibc upgrade where the version changes
(like 2.2.3-foo -> 2.2.4-bar) when the %trigger is run, there are
2 libc-*.so files so it becomes confused.
As I've mailed some long time ago, you should be using ldconfig output
to see what library you should copy, or at least run ldconfig and then look
what libc.so.6 symlink points to.
Comment 2 Bernhard Rosenkraenzer 2001-08-20 06:03:51 EDT
*** Bug 51943 has been marked as a duplicate of this bug. ***
Comment 3 Bernhard Rosenkraenzer 2001-08-20 06:09:01 EDT
Fixed in 4.0-8 (4.0-7 fixed the copy() script only, not the LIBCVER variable)
Comment 4 Jonathan Kamens 2001-08-21 09:47:57 EDT
I got these errors when upgrading from 4.0-7 to 4.0-8.  Does this means that
there's still a problem somewhere, or that the bugs were in a postuninstall
script from 4.0-7?

ls: /var/ftp/lib/libc-*.so: No such file or directory
ls: /lib/ld-.so.so: No such file or directory
cp: cannot stat `': No such file or directory
ls: /lib/libc-.so.so: No such file or directory
cp: cannot stat `': No such file or directory
ls: /lib/libnsl-.so.so: No such file or directory
cp: cannot stat `': No such file or directory
ls: /lib/libnss_files-.so.so: No such file or directory
cp: cannot stat `': No such file or directory
Comment 5 Jonathan Kamens 2001-08-22 06:33:29 EDT
After the error noted above, I get this when I run "rpm --verify anonftp" with
4.0-8:

root@jik:~/tmp/addresses/rwback!1# rpm --verify anonftp
md5sum: /var/ftp/lib/lib*-*.so: No such file or directory
5.......   /var/ftp/lib/lib*-*.so

Either this isn't actually fixed, or there's an issue with upgrading between
Rawhide versions of this package.  Since I'm not sure which of these is the
case, I'm reopening this bug so it doesn't get lost.
Comment 6 Bernhard Rosenkraenzer 2001-08-22 08:10:09 EDT
4.0-9 fixes it for good
Comment 7 Jakub Jelinek 2001-08-22 08:39:25 EDT
*** Bug 52212 has been marked as a duplicate of this bug. ***
Comment 8 Jakub Jelinek 2001-11-30 18:17:15 EST
*** Bug 56950 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.