Bug 51668 - threading symbols in mutt running in screen in a gnome terminal
threading symbols in mutt running in screen in a gnome terminal
Status: CLOSED WONTFIX
Product: Red Hat Public Beta
Classification: Retired
Component: screen (Show other bugs)
roswell
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Lon Hohberger
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-13 15:03 EDT by Jack Neely
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-25 14:40:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jack Neely 2001-08-13 15:03:36 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.3) Gecko/20010803

Description of problem:
The threading symbols in mutt do not display correctly when running
mutt inside a screen session inside a gnome terminal.  I see m, q, and *
rather than the proper lines I see with the screen session running from the
console.

How reproducible:
Always

Steps to Reproduce:
1.in a gnome terminal run "screen mutt"
2.sort messages by thread 
3.observe strange characters that represent the threads rather than the
expected lines and right angles and the like
	

Actual Results:  2504 N   Aug 12 Nerijus Baliuna (  25) x       tq>       
                      2505 N   Aug 12 Robert Love     (  36) x       x mq>
                           2506 N   Aug 12 Manuel McLure   (  29) x      
tq>                              2507 N   Aug 12 Manuel McLure   ( 102) x 
     x mq>                            2508 N   Aug 12 Linus Torvalds  ( 
21) x       x   mq>                          2509 N   Aug 12 Manuel McLure
  (  27) x       x     mq>                        2510 N   Aug 12 Linus
Torvalds  (  42) x       x       mq>                      2511 N   Aug 12
Manuel McLure   (  30) x       x         mq>                    2512 N  
Aug 12 Paul G. Allen   (  18) x       x           mq>                  2513
N   Aug 12 Linus Torvalds  (  26) x       x             tq>               
2514 N   Aug 12 Paul G. Allen   (  58) x       x             x mq>        
     2515 N   Aug 12 Nicholas Knight (  29) x       x             x   mq> 
          2516 N   Aug 12 Justin A        (  31) x       x             tq>
               2517 N   Aug 12 Mike Frisch     (  23) x       x           
 mq>                2518 N   Aug 12 Linus Torvalds  (  18) x       tq>    
                         



Expected Results:  


Additional info:

I *think* this may be a bug in slang
Comment 1 Bill Nottingham 2001-08-13 15:06:28 EDT
I'd guess this has a lot to do with screen's terminfo/termcap entries.
Comment 2 Lon Hohberger 2002-11-11 12:01:13 EST
In releases prior to 8.0, we shipped screen with UTF-8 translation enabled. 
Unfortunately, screen's UTF-8 handling doesn't appear to work very well, so in
8.0, we disabled it.  So, this bug is present (in different forms) on Roswell,
7.2 and 7.3.  

In 8.0, a similar behavior occurs - except that in this case, it's not a bug
(because we explicitly disabled UTF-8 support in screen).

I recommend placing the following line in your .muttrc:

set ascii_chars=yes

It is less visually clean, but worked in all LANG/TERM settings I tried on 7.2
and 8.0.  My apologies, but since I received this bug a "bit" late and it's
fixed in our current release, I'm not going to fix it.


Note You need to log in before you can comment on or make changes to this bug.