Bug 51702 - textutils not being upgraded
textutils not being upgraded
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: textutils (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-13 22:20 EDT by Peter Bowen
Modified: 2007-04-18 12:35 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-14 15:40:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Bowen 2001-08-13 22:20:10 EDT
textutils is not being updated during upgrade from RHL6.2

6.2 had version 2.0a, and had an errata that brought the version up to 2.0e
 After upgrading to beta3, textutils is still at versions 2.0e, while beta3
has 2.0.14
Comment 1 Bernhard Rosenkraenzer 2001-08-14 08:39:07 EDT
textutils doesn't have an Epoch, and the version number increased... Assigning 
to anaconda
Comment 2 Glen Foster 2001-08-14 15:04:51 EDT
This defect considered MUST-FIX for Fairfax.
Comment 3 Bill Nottingham 2001-08-14 15:26:17 EDT
textutils needs an epoch.

rpm version compares are done by '.' separated sections. So, for this case:

2 == 2

0 < 0e

The 14 doesn't even come into the equation.

(jbj, am I misunderstanding this?)
Comment 4 Jeff Johnson 2001-08-14 15:29:31 EDT
Nod, needs an epoch, or other surgery on the '0'
piece in the version.
Comment 5 Bernhard Rosenkraenzer 2001-08-14 15:31:18 EDT
Odd, rpm -Fvh on the package worked.
Comment 6 Peter Bowen 2001-08-14 15:38:31 EDT
bero: you are probably using RPM v4.0.2.  As I pointed out in Bug #51333, RPM
v4.0.3 changes the way package comparissons are handled.  So if you do the
upgrade from 6.2 -> 7.1 -> 7.2, it will work correctly, but if you go from 6.2
-> 7.2 it breaks.  

And the actually break down of the comparisson is:
2 == 2
0 == 0
e > 14
because the transition from digits to alpha chars has an implied .
Comment 7 Jeff Johnson 2001-08-14 15:40:33 EDT
See bugzilla #50977 for what needs doing. Meanwhile,
since some upgrade path with some version or rpm is failing
to do the right thing, add the epoch just in case ...
Comment 8 Bernhard Rosenkraenzer 2001-08-14 15:43:43 EDT
Added in 2.0.14-2

Note You need to log in before you can comment on or make changes to this bug.