Bug 51708 - matrox dri fails with kernel errata
matrox dri fails with kernel errata
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-14 00:56 EDT by Need Real Name
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-21 03:18:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X log file (22.52 KB, text/plain)
2001-08-14 00:58 EDT, Need Real Name
no flags Details
x config file (1.99 KB, text/plain)
2001-08-14 00:59 EDT, Need Real Name
no flags Details
startx output from 2.2.17-14 showing dri module loading (10.98 KB, text/plain)
2001-08-21 03:18 EDT, Need Real Name
no flags Details

  None (edit)
Description Need Real Name 2001-08-14 00:56:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.2.19-7.0.8 i586; Nav)

Description of problem:
After upgrading to the 2.2.19 errata (this includes 6.2.1, 6.2.7, and
7.0.8) the mga module will no longer enable dri when starting X on a G400. 
It fails in MGADRIScreenInit:

(EE) MGA(0): [drm] MGADRIScreenInit failed (DRM version = 2.0.0, expected
1.0.x).  Disabling DRI.


How reproducible:
Always

Steps to Reproduce:
1. Install a base 7.0 system
2. Apply the kernel errata to bring the kernel up to 2.2.19
3. startx
	

Actual Results:  The X server starts, but does not enable dri as it did
before.  If you revert back to a 2.2.16 or 2.2.17 kernel, it does.

Expected Results:  DRI should be enabled, since this worked "out of the
box".

Additional info:

I was getting SEGVs until I added the following lines to XF86Config-4 in
the "Modules" section, now I get the "Disabling DRI" message.

        Load  "ddc"    
        Load  "vgahw"  
        Load  "xaa"
Comment 1 Need Real Name 2001-08-14 00:58:49 EDT
Created attachment 27673 [details]
X log file
Comment 2 Need Real Name 2001-08-14 00:59:37 EDT
Created attachment 27674 [details]
x config file
Comment 3 Mike A. Harris 2001-08-15 07:34:20 EDT
Well, XFree86 in 7.0 has not changed, so...
I've Cc'd Arjan for comment.  If this is a real bug, it
must be a kernel DRM bug... Arjan?
Comment 4 Arjan van de Ven 2001-08-15 07:40:08 EDT
6.2.1 and 7.0.1 have the exact same DRM as 2.2.16 (a patch was added to make
sure of this).
Comment 5 Need Real Name 2001-08-21 03:18:35 EDT
Created attachment 28614 [details]
startx output from 2.2.17-14 showing dri module loading
Comment 6 Mike A. Harris 2002-01-27 04:58:41 EST
If the after the kernel upgrade DRI failed, then IMHO, the kernel
must have changed in some way to cause this.  I've got a G400
running rigth now with our current 7.2 XFree86 and kernel, and DRI
is working so I'm closing this bug as fixed in current release.

Note You need to log in before you can comment on or make changes to this bug.