Red Hat Bugzilla – Bug 517193
Add epoch to icu4j Requires/BuildRequires
Last modified: 2009-08-13 08:36:02 EDT
Description of problem:
Upgrading to eclipse-platform.3.5.0-0.4.0.fc12 failed to upgrade icu4j-eclipse-4.0.1-2.fc12 to icu4j-eclipse-4.0.1-3.fc12. Eclipse fails to load with the older version of icu4j-eclipse.
Steps to Reproduce:
1.Start from eclipse-platform.3.5.0-0.3.9.fc12 and rcp, swt, and jdt and icu4j-eclipse-4.0.1-2.fc12
2.Upgrade eclipse-platform to 3.5.0-0.4.0.fc12
icu4j-eclipse does NOT get upgraded
icu4j-eclipse should have be upgraded since it is required for this version of eclipse
According to Andrew Overholt, the following happened
If you look at the RPM dependencies, you'll see that eclipse-rcp has a hard requirement on icu4j-eclipse >= 4.0.1-3 (or something like that) yet rpm -qV
eclipse-rcp won't show anything if 4.0.1-2 is installed.
icu4j-eclipse has an epoch of 1, so it will satisfy any versioned dependency which doesn't specify the epoch (unspecified epoch is considered zero by rpm). To have the desired effect, the dependency needs to state the epoch too:
Requires: icu4j-eclipse >= 1:4.0.1-3
Thanks, Panu. I thought I was going crazy :)
Updating summary. Alex fixed this a few hours ago in CVS.
Welcome to the "Epochs considered harmful" club :)