Bug 517193 - Add epoch to icu4j Requires/BuildRequires
Add epoch to icu4j Requires/BuildRequires
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-12 17:33 EDT by shmuel siegel
Modified: 2009-08-13 08:36 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-13 08:00:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description shmuel siegel 2009-08-12 17:33:34 EDT
Description of problem:
Upgrading to eclipse-platform.3.5.0-0.4.0.fc12 failed to upgrade icu4j-eclipse-4.0.1-2.fc12 to icu4j-eclipse-4.0.1-3.fc12. Eclipse fails to load with the older version of icu4j-eclipse.


Steps to Reproduce:
1.Start from eclipse-platform.3.5.0-0.3.9.fc12 and rcp, swt, and jdt and icu4j-eclipse-4.0.1-2.fc12
2.Upgrade eclipse-platform to 3.5.0-0.4.0.fc12
  
Actual results:
icu4j-eclipse does NOT get upgraded

Expected results:
icu4j-eclipse should have be upgraded since it is required for this version of eclipse

Additional info:
Comment 1 shmuel siegel 2009-08-12 17:37:47 EDT
According to Andrew Overholt, the following happened

If you look at the RPM dependencies, you'll see that eclipse-rcp has a hard requirement on icu4j-eclipse >= 4.0.1-3 (or something like that) yet rpm -qV
eclipse-rcp won't show anything if 4.0.1-2 is installed.
Comment 2 Panu Matilainen 2009-08-13 02:47:35 EDT
icu4j-eclipse has an epoch of 1, so it will satisfy any versioned dependency which doesn't specify the epoch (unspecified epoch is considered zero by rpm). To have the desired effect, the dependency needs to state the epoch too:

Requires: icu4j-eclipse >= 1:4.0.1-3
Comment 3 Andrew Overholt 2009-08-13 07:40:14 EDT
Thanks, Panu.  I thought I was going crazy :)
Comment 4 Andrew Overholt 2009-08-13 08:00:14 EDT
Updating summary.  Alex fixed this a few hours ago in CVS.
Comment 5 Panu Matilainen 2009-08-13 08:36:02 EDT
Welcome to the "Epochs considered harmful" club :)

Note You need to log in before you can comment on or make changes to this bug.