Bug 517261 - sealert traceback
Summary: sealert traceback
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: setroubleshoot
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-13 10:04 UTC by Tim Waugh
Modified: 2009-08-13 15:41 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-13 15:41:16 UTC


Attachments (Terms of Use)

Description Tim Waugh 2009-08-13 10:04:15 UTC
Description of problem:
When an AVC is generated and I try to view it using the setroubleshoot icon, I get this in .xsession-errors:

Traceback (most recent call last):
  File "/usr/bin/sealert", line 36, in <module>
    import slip.dbus.service
ImportError: No module named slip.dbus.service

Looks like a missing dependency on python-slip but it isn't as simple as that.  If I install python-slip first I get a different traceback:

Traceback (most recent call last):
  File "/usr/bin/sealert", line 36, in <module>
    import slip.dbus.service
ImportError: No module named dbus.service

Version-Release number of selected component (if applicable):
setroubleshoot-server-2.2.18-1.fc12.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Click on the icon.

Comment 1 Daniel Walsh 2009-08-13 15:41:16 UTC
Adding

Requires: python-slip-dbus


Fixed in setroubleshoot-2.2.18-2.fc12


Note You need to log in before you can comment on or make changes to this bug.