Bug 517276 - v7 always run suspend test before specified test on laptop
Summary: v7 always run suspend test before specified test on laptop
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests)
Version: 1.0
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
: ---
Assignee: Greg Nichols
QA Contact: Lawrence Lim
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-13 11:01 UTC by Yan Tian
Modified: 2014-03-26 01:00 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-13 13:17:42 UTC


Attachments (Terms of Use)

Description Yan Tian 2009-08-13 11:01:52 UTC
Description of problem:
When run v7 tests on laptop, it always run suspend test firstly, then run the specified test.

[root@dhcp-65-171 ~]# v7 run --test bluray
loaded results /var/v7/results.xml
OS Version: Red Hat Enterprise Linux Server release 5.4 (Tikanga)
Kernel RPM: kernel-2.6.18-159.el5
v7 version 1.0, release 14
saved test plan to /var/v7/results.xml

Running bluray:
---------------------------------
suspend               acpi_C1F4
bluray     hda        storage_serial_HB16_014812
info                                                        - DISABLED

running suspend on /org/freedesktop/Hal/devices/acpi_C1F4
mkdir -p /tmp/v7-suspend-oAf-IO/mnt/tests/V7/v7/suspend
cp -a testinfo.desc runtest.sh suspend.py Makefile /tmp/v7-suspend-oAf-IO/mnt/tests/V7/v7/suspend
install -m 0755 runtest.sh /tmp/v7-suspend-oAf-IO/mnt/tests/V7/v7/suspend
make OUTPUTFILE=/var/log/v7/runs/3/suspend/output.log RUNMODE=forced UDI=/org/freedesktop/Hal/devices/acpi_C1F4 DEVICE= TESTSERVER=unknown run
chmod a+x ./runtest.sh ./suspend.py
./runtest.sh
/tmp/v7-suspend-oAf-IO/mnt/tests/V7/v7/suspend/suspend.py
Running ./suspend.py:
This test will suspend the operating system.
Please resume by pressing the power button after suspend has completed.
 suspend?  (y|n) n
response: n
...finished running ./suspend.py, exit code=1

Version-Release number of selected component (if applicable):
v7-1.0-14.el5

How reproducible:
always

Steps to Reproduce:
1.
2.
3.
  
Actual results:
run suspend test firstly, then run specified test

Expected results:
not run suspend, but run specified test directly

Additional info:

Comment 1 Greg Nichols 2009-08-13 13:17:42 UTC
This works as intended.   The suspend test is required to run first on capable systems as a means of testing the systems ability to function following resume.


Note You need to log in before you can comment on or make changes to this bug.