Bug 517280 - xfce4-session starts lots of xfwm4 window-manages in parallel
Summary: xfce4-session starts lots of xfwm4 window-manages in parallel
Keywords:
Status: CLOSED DUPLICATE of bug 512522
Alias: None
Product: Fedora
Classification: Fedora
Component: xfce4-session
Version: 11
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-13 11:17 UTC by Kai Hambrecht
Modified: 2009-08-13 17:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-13 17:09:16 UTC


Attachments (Terms of Use)

Description Kai Hambrecht 2009-08-13 11:17:53 UTC
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.1.2) Gecko/20090803 Fedora/3.5.2-2.fc11 Firefox/3.5.2

After login from gdm to a xfce desktop, the xfce4-session does start lots of (i.e about 100) xfwm4 window managers in parallel. Therefore it takes about 10-15 minutes for the Desktop to complete (showing "Starting window manager" in splash screen). In summary, a few 1000 xfwm4 processes gets started and will exit immediately since there is already another window-manager running (of course, the first one of these xfwm4).

Also lots of messages in ~/.xsession-errors like:
** (xfwm4:16768): WARNING **: Another Window Manager is already running


As a workaround, i have renamed "xfwm4" to "_xfwm4", so xfce4-session still tries to call the (now non-existing) xfwm4 binary a few thousand times, but this takes only about 5 minutes to complete.

Reproducible: Always

Steps to Reproduce:
1. login to xfce desktop from gdm
2. ... wait.
3.
Actual Results:  
xfce Desktop takes lots of time to complete, starting (and exiting) 1000's of xfwm4

Expected Results:  
xfce Desktop (e.g. xfce4-.session) should start xfwm4 only once.

Comment 1 Kevin Fenzi 2009-08-13 17:09:16 UTC
This is the same issue as bug 512522 
(you can find the link to the upstream bug there as well).

*** This bug has been marked as a duplicate of bug 512522 ***


Note You need to log in before you can comment on or make changes to this bug.