Bug 517303 - setroubleshoot: SELinux is preventing the dbus-daemon from using potentially mislabeled files (root).
Summary: setroubleshoot: SELinux is preventing the dbus-daemon from using potenti...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: setroubleshoot_trace_hash:7b3b03ae750...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-13 12:55 UTC by Rex Dieter
Modified: 2009-11-06 01:21 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-13 15:56:58 UTC


Attachments (Terms of Use)

Description Rex Dieter 2009-08-13 12:55:25 UTC
The following was filed automatically by setroubleshoot:

Summary:

SELinux is preventing the dbus-daemon from using potentially mislabeled files
(root).

Detailed Description:

SELinux has denied dbus-daemon access to potentially mislabeled file(s) (root).
This means that SELinux will not allow dbus-daemon to use these files. It is
common for users to edit files in their home directory or tmp directories and
then move (mv) them to system directories. The problem is that the files end up
with the wrong file context which confined applications are not allowed to
access.

Allowing Access:

If you want dbus-daemon to access this files, you need to relabel them using
restorecon -v 'root'. You might want to relabel the entire directory using
restorecon -R -v 'root'.

Additional Information:

Source Context                system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023
Target Context                system_u:object_r:admin_home_t:s0
Target Objects                root [ dir ]
Source                        dbus-daemon
Source Path                   /bin/dbus-daemon
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           dbus-1.2.16-4.fc12
Target RPM Packages           filesystem-2.4.27-1.fc12
Policy RPM                    selinux-policy-3.6.26-8.fc12
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   home_tmp_bad_labels
Host Name                     (removed)
Platform                      Linux (removed)
                              2.6.31-0.125.rc5.git2.fc12.x86_64 #1 SMP Tue Aug 4
                              02:59:17 EDT 2009 x86_64 x86_64
Alert Count                   1
First Seen                    Thu 13 Aug 2009 07:41:50 AM EDT
Last Seen                     Thu 13 Aug 2009 07:41:50 AM EDT
Local ID                      c7ecc933-4258-4276-8ccd-30ffc2b31d8a
Line Numbers                  

Raw Audit Messages            

node=(removed) type=AVC msg=audit(1250163710.576:30513): avc:  denied  { search } for  pid=2199 comm="dbus-daemon" name="root" dev=dm-0 ino=24587 scontext=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:admin_home_t:s0 tclass=dir

node=(removed) type=SYSCALL msg=audit(1250163710.576:30513): arch=c000003e syscall=2 success=yes exit=0 a0=7fc8f20d5ee0 a1=90800 a2=1 a3=0 items=0 ppid=2198 pid=2199 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="dbus-daemon" exe="/bin/dbus-daemon" subj=system_u:system_r:xdm_dbusd_t:s0-s0:c0.c1023 key=(null)


audit2allow suggests:

#============= xdm_dbusd_t ==============
allow xdm_dbusd_t admin_home_t:dir search;

Comment 1 Rex Dieter 2009-08-13 12:56:01 UTC
happened when testing recent f12-kde live image, when doing suspend/resume.

Comment 2 Daniel Walsh 2009-08-13 15:56:58 UTC
This is dontaudited in selinux-policy-3.6.26-10.fc12.noarch


Note You need to log in before you can comment on or make changes to this bug.