Bug 517340 - coredump from wish /usr/bin/gitk -- refs/bisect/bad ...
Summary: coredump from wish /usr/bin/gitk -- refs/bisect/bad ...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: tk
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Nikola Pajkovsky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-13 14:56 UTC by Zdenek Kabelac
Modified: 2014-02-02 22:13 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-13 15:22:17 UTC


Attachments (Terms of Use)

Description Zdenek Kabelac 2009-08-13 14:56:32 UTC
Description of problem:

Tried to visualize git bisect - I've got following wish coredump:
(unsure whether it belongs to tk/tcl/git - feel free to move)

Core was generated by `wish /usr/bin/gitk -- refs/bisect/bad --not refs/bisect/good-0bcd783c1f0396b684'.
Program terminated with signal 6, Aborted.
#0  0x00007f449dbb5675 in raise () from /lib64/libc.so.6
Missing separate debuginfos, use: debuginfo-install expat-2.0.1-7.x86_64 fontconfig-2.7.1-1.fc12.x86_64 freetype-2.3.9-6.fc12.x86_64 glibc-2.10.90-12.x86_64 libX11-1.2.99-3.20090712.fc12.x86_64 libXau-1.0.4-7.fc12.x86_64 libXft-2.1.13-4.fc12.x86_64 libXrender-0.9.4-7.fc12.x86_64 libgcc-4.4.1-3.x86_64 libxcb-1.3-2.fc12.x86_64
(gdb) bt
#0  0x00007f449dbb5675 in raise () from /lib64/libc.so.6
#1  0x00007f449dbb6e55 in abort () from /lib64/libc.so.6
#2  0x00007f449dbf1fd3 in __libc_message () from /lib64/libc.so.6
#3  0x00007f449dc7bf17 in __fortify_fail () from /lib64/libc.so.6
#4  0x00007f449dc79e80 in __chk_fail () from /lib64/libc.so.6
#5  0x00007f449f0888a9 in strcpy (__src=<value optimized out>, __dest=<value optimized out>) from /usr/lib64/libtcl8.5.so
#6  TraceVariableObjCmd (__src=<value optimized out>, __dest=<value optimized out>) at /usr/src/debug/tcl8.5.7/generic/tclTrace.c:912
#7  0x00007f449f087fe5 in Tcl_TraceObjCmd (dummy=<value optimized out>, interp=0x196c260, objc=6, objv=0x196f170)
    at /usr/src/debug/tcl8.5.7/generic/tclTrace.c:249
#8  0x00007f449efed7d7 in TclEvalObjvInternal (interp=0x196c260, objc=<value optimized out>, objv=<value optimized out>, 
    command=0xffffffffffffffff <Address 0xffffffffffffffff out of bounds>, length=-1, flags=<value optimized out>)
    at /usr/src/debug/tcl8.5.7/generic/tclBasic.c:3690
#9  0x00007f449f03622a in TclExecuteByteCode (interp=0x196c260, codePtr=<value optimized out>) at /usr/src/debug/tcl8.5.7/generic/tclExecute.c:2348
#10 0x00007f449f03e289 in TclCompEvalObj (interp=0x196c260, objPtr=0x1a735d0, invoker=0x196f0d0, word=1)
    at /usr/src/debug/tcl8.5.7/generic/tclExecute.c:1474
#11 0x00007f449efeec56 in TclEvalObjEx (interp=0x196c260, objPtr=0x1a735d0, flags=0, invoker=0x196f0d0, word=-1647610112)
    at /usr/src/debug/tcl8.5.7/generic/tclBasic.c:5095
#12 0x00007f449f000bb8 in Tcl_SwitchObjCmd (dummy=<value optimized out>, interp=<value optimized out>, objc=6, objv=<value optimized out>)
    at /usr/src/debug/tcl8.5.7/generic/tclCmdMZ.c:3863
#13 0x00007f449efed7d7 in TclEvalObjvInternal (interp=0x196c260, objc=<value optimized out>, objv=<value optimized out>, 
    command=0x1a3e155 "switch -exact -- [tk windowingsystem] {\n    \"x11\" {\n\tevent add <<Cut>> <Control-Key-x> <Key-F20> <Control-Lock-Key-X>\n\tevent add <<Copy>> <Control-Key-c> <Key-F16> <Control-Lock-Key-C>\n\tevent add <<Pa"..., length=1968, flags=<value optimized out>)
    at /usr/src/debug/tcl8.5.7/generic/tclBasic.c:3690
#14 0x00007f449efee0af in TclEvalEx (interp=0x196c260, script=<value optimized out>, numBytes=<value optimized out>, flags=<value optimized out>, 
    line=<value optimized out>) at /usr/src/debug/tcl8.5.7/generic/tclBasic.c:4338
#15 0x00007f449f05a7f1 in Tcl_FSEvalFileEx (interp=0x196c260, pathPtr=0x1a33110, encodingName=<value optimized out>)
    at /usr/src/debug/tcl8.5.7/generic/tclIOUtil.c:1814
#16 0x00007f449f0052f5 in Tcl_SourceObjCmd (dummy=<value optimized out>, interp=0x196c260, objc=<value optimized out>, objv=0x1a33480)
    at /usr/src/debug/tcl8.5.7/generic/tclCmdMZ.c:955
#17 0x00007f449efed7d7 in TclEvalObjvInternal (interp=0x196c260, objc=<value optimized out>, objv=<value optimized out>, command=0x0, length=0, 
    flags=<value optimized out>) at /usr/src/debug/tcl8.5.7/generic/tclBasic.c:3690
#18 0x00007f449efee9f3 in Tcl_EvalObjv (interp=0x6e13, objc=28179, objv=0x6, flags=0) at /usr/src/debug/tcl8.5.7/generic/tclBasic.c:3886
#19 0x00007f449efeedb2 in TclEvalObjEx (interp=0x196c260, objPtr=0x1a2d0d0, flags=0, invoker=<value optimized out>, word=<value optimized out>)
    at /usr/src/debug/tcl8.5.7/generic/tclBasic.c:4983
#20 0x00007f449f0787df in Tcl_UplevelObjCmd (dummy=<value optimized out>, interp=0x196c260, objc=<value optimized out>, objv=0x196ec58)
    at /usr/src/debug/tcl8.5.7/generic/tclProc.c:938
#21 0x00007f449efed7d7 in TclEvalObjvInternal (interp=0x196c260, objc=<value optimized out>, objv=<value optimized out>, 
    command=0xffffffffffffffff <Address 0xffffffffffffffff out of bounds>, length=-1, flags=<value optimized out>)
    at /usr/src/debug/tcl8.5.7/generic/tclBasic.c:3690
#22 0x00007f449f03622a in TclExecuteByteCode (interp=0x196c260, codePtr=<value optimized out>) at /usr/src/debug/tcl8.5.7/generic/tclExecute.c:2348
#23 0x00007f449f077eb8 in TclObjInterpProcCore (interp=0x196c260, procNameObj=<value optimized out>, skip=<value optimized out>, 
    errorProc=<value optimized out>) at /usr/src/debug/tcl8.5.7/generic/tclProc.c:1748
#24 0x00007f449efed7d7 in TclEvalObjvInternal (interp=0x196c260, objc=<value optimized out>, objv=<value optimized out>, command=0x0, length=0, 
    flags=<value optimized out>) at /usr/src/debug/tcl8.5.7/generic/tclBasic.c:3690
#25 0x00007f449efee9f3 in Tcl_EvalObjv (interp=0x6e13, objc=28179, objv=0x6, flags=0) at /usr/src/debug/tcl8.5.7/generic/tclBasic.c:3886
#26 0x00007f449efeedb2 in TclEvalObjEx (interp=0x196c260, objPtr=0x1a02a40, flags=0, invoker=<value optimized out>, word=<value optimized out>)
    at /usr/src/debug/tcl8.5.7/generic/tclBasic.c:4983
#27 0x00007f449f0787df in Tcl_UplevelObjCmd (dummy=<value optimized out>, interp=0x196c260, objc=<value optimized out>, objv=0x196e960)
    at /usr/src/debug/tcl8.5.7/generic/tclProc.c:938
#28 0x00007f449efed7d7 in TclEvalObjvInternal (interp=0x196c260, objc=<value optimized out>, objv=<value optimized out>, 
    command=0xffffffffffffffff <Address 0xffffffffffffffff out of bounds>, length=-1, flags=<value optimized out>)
    at /usr/src/debug/tcl8.5.7/generic/tclBasic.c:3690
---Type <return> to continue, or q <return> to quit---
#29 0x00007f449f03622a in TclExecuteByteCode (interp=0x196c260, codePtr=<value optimized out>) at /usr/src/debug/tcl8.5.7/generic/tclExecute.c:2348
#30 0x00007f449f077eb8 in TclObjInterpProcCore (interp=0x196c260, procNameObj=<value optimized out>, skip=<value optimized out>, 
    errorProc=<value optimized out>) at /usr/src/debug/tcl8.5.7/generic/tclProc.c:1748
#31 0x00007f449efed7d7 in TclEvalObjvInternal (interp=0x196c260, objc=<value optimized out>, objv=<value optimized out>, 
    command=0xffffffffffffffff <Address 0xffffffffffffffff out of bounds>, length=-1, flags=<value optimized out>)
    at /usr/src/debug/tcl8.5.7/generic/tclBasic.c:3690
#32 0x00007f449efed927 in TclEvalObjvInternal (interp=0x196c260, objc=<value optimized out>, objv=<value optimized out>, 
    command=0xffffffffffffffff <Address 0xffffffffffffffff out of bounds>, length=-1, flags=<value optimized out>)
    at /usr/src/debug/tcl8.5.7/generic/tclBasic.c:3830
#33 0x00007f449f03622a in TclExecuteByteCode (interp=0x196c260, codePtr=<value optimized out>) at /usr/src/debug/tcl8.5.7/generic/tclExecute.c:2348
#34 0x00007f449f077eb8 in TclObjInterpProcCore (interp=0x196c260, procNameObj=<value optimized out>, skip=<value optimized out>, 
    errorProc=<value optimized out>) at /usr/src/debug/tcl8.5.7/generic/tclProc.c:1748
#35 0x00007f449efed7d7 in TclEvalObjvInternal (interp=0x196c260, objc=<value optimized out>, objv=<value optimized out>, 
    command=0x7f449f3e1d8d "tkInit", length=6, flags=<value optimized out>) at /usr/src/debug/tcl8.5.7/generic/tclBasic.c:3690
#36 0x00007f449efee0af in TclEvalEx (interp=0x196c260, script=<value optimized out>, numBytes=<value optimized out>, flags=<value optimized out>, 
    line=<value optimized out>) at /usr/src/debug/tcl8.5.7/generic/tclBasic.c:4338
#37 0x00007f449efee7ed in Tcl_Eval (interp=0x6e13, script=0x6e13 <Address 0x6e13 out of bounds>) at /usr/src/debug/tcl8.5.7/generic/tclBasic.c:4823
#38 0x00007f449f33d6de in Initialize (interp=0x196c260) at /usr/src/debug/tk8.5.7/generic/tkWindow.c:3252
#39 0x00000000004009a6 in Tcl_AppInit (interp=0x196c260) at /usr/src/debug/tk8.5.7/unix/tkAppInit.c:98
#40 0x00007f449f32fc50 in Tk_MainEx (argc=-1, argv=<value optimized out>, appInitProc=<value optimized out>, interp=0x196c260)
    at /usr/src/debug/tk8.5.7/generic/tkMain.c:259
#41 0x0000000000400a2c in main (argc=12, argv=0x7fff2fa6c158) at /usr/src/debug/tk8.5.7/unix/tkAppInit.c:68



Version-Release number of selected component (if applicable):
tk-8.5.7-1.fc12.x86_64
tcl-8.5.7-3.fc12.x86_64
git-1.6.4-1.fc12.x86_64


How reproducible:


Steps to Reproduce:
1.runnig git bisect visualize
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Nikola Pajkovsky 2009-08-13 15:11:03 UTC
Hello, 
   use newer build of tcl

https://koji.fedoraproject.org/koji/buildinfo?buildID=126508

Give me echo if it still present.

Have a nice day ;)

Comment 2 Zdenek Kabelac 2009-08-13 15:19:00 UTC
Ok - seems to be fixed with this release tcl-8.5.7-4.fc12.x86_64.rpm 
I guess the bug could be closed.

Thanks


Note You need to log in before you can comment on or make changes to this bug.