Bug 51739 - Cannot enable job control on ksh script run through rsh
Cannot enable job control on ksh script run through rsh
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: pdksh (Show other bugs)
7.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-14 12:21 EDT by Michael Smith
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-14 12:24:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Korn Shell script to put program into new process group (33 bytes, patch)
2001-08-14 12:24 EDT, Michael Smith
no flags Details | Diff

  None (edit)
Description Michael Smith 2001-08-14 12:21:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.5 i686)

Description of problem:
In an attempt to fix a problem with LSF (from Platform Computing),
I am using a ksh script to run jobs remotely.  The purpose of this
ksh script is simply to put another program into its own process
group to prevent SIGHUP from being propogated to this program.

Unfortunately, this script does not work on Linux (but it does work
on all version of Solaris that I've tried) since the command 'set -m'
within the script complains that it has no controlling tty, and thus
it cannot enable job control.

The script attached and is called 'newPG.ksh'.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.run: rsh <machine> newPG.ksh whoami


	

Actual Results:  /home/system/scripts/newPG.ksh: No controlling tty (open
/dev/tty: Device not configured)
/home/system/scripts/newPG.ksh: Can't find tty file descriptor
/home/system/scripts/newPG.ksh: warning: won't have full job control
[1] + Done                 exec $*
michael                                                                                          

Expected Results:  It should simply have printed 'michael' without any
warnings.

Additional info:
Comment 1 Michael Smith 2001-08-14 12:24:52 EDT
Created attachment 27754 [details]
Korn Shell script to put program into new process group
Comment 2 Trond Eivind Glomsrxd 2001-08-15 14:32:00 EDT
rsh doesn't allocate a tty... "ssh -t" will, OTOH.

Note You need to log in before you can comment on or make changes to this bug.