Bug 517481 - The items such as "System eth0" in tab "Wired" of "Network Connetctions" dialog box are redundant
Summary: The items such as "System eth0" in tab "Wired" of "Network Connetctions" dial...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 12
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 519210 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-14 09:38 UTC by Luo Fei
Modified: 2010-02-09 01:40 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-02-09 01:38:57 UTC


Attachments (Terms of Use)

Description Luo Fei 2009-08-14 09:38:42 UTC
Description of problem:
    the items "System eth0" in tab "Wired" of "Network Connetctions" dialog box are --redundant-- after running the cmd "service NetworkManager restart" with this dialog box openning!
     run this cmd with the dialog box openning one time and the item is added one time, but after reopenning this dialog box, the items in are right.

Version-Release number of selected component (if applicable):
NetworkManager-vpnc-0.7.0.99-3.fc12.x86_64
NetworkManager-0.7.995-1.git20090804.fc12.x86_64
NetworkManager-gnome-0.7.995-1.git20090804.fc12.x86_64
NetworkManager-openvpn-0.7.1-2.git20090714.fc12.x86_64
NetworkManager-glib-0.7.995-1.git20090804.fc12.x86_64

How reproducible:
always

Steps to Reproduce:
1.start up the system
2.Right click on the NetworkManager applet in the system tray
3.click on Edit connections
4.run the cmd "service NetworkManager restart"
  
Actual results:
  the items "System eth0" in Wired tab are redundant. the number of item "System eth0 " increases with the times of this cmd run.   

Expected results:
  the items "System eth0" in Wired tab are just corresponding to the real item.

Additional info:
   maybe should clean the items in tab first when running this cmd.

Comment 2 Bug Zapper 2009-11-16 11:26:45 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 3 Dan Williams 2010-02-09 01:38:57 UTC
I'm pretty sure this has been fixed by now.

Comment 4 Dan Williams 2010-02-09 01:40:48 UTC
*** Bug 519210 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.