Bug 517499 - Error message on install
Summary: Error message on install
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-14 11:57 UTC by Tim Waugh
Modified: 2009-08-14 13:18 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-14 13:18:05 UTC


Attachments (Terms of Use)

Description Tim Waugh 2009-08-14 11:57:37 UTC
Description of problem:
Upgrading from these packages:

selinux-policy-3.6.26-8.fc12
policycoreutils-2.0.68-1.fc12

to these:

selinux-policy-3.6.26-11.fc12.noarch
policycoreutils-2.0.71-2.fc12.x86_64

gave error messages:


# rpm -Fvh selinux-policy-*.noarch.rpm policycoreutils-*.rpm
Preparing...                ########################################### [100%]
   1:policycoreutils        ########################################### [ 25%]
   2:selinux-policy         ########################################### [ 50%]
/usr/share/selinux/devel/include/system/unconfined.if: Syntax error on line 130 $1 [type=IDENTIFIER]
/usr/share/selinux/devel/include/system/unconfined.if: Syntax error on line 136 ' [type=SQUOTE]
   3:policycoreutils-python ########################################### [ 75%]
   4:selinux-policy-targeted########################################### [100%]

Comment 1 Daniel Walsh 2009-08-14 13:18:05 UTC
Ok this is an update problem. That should not happen other then this one update.  Should not happen on installs.  The problem is the policycoretils-python package got updated after the selinux-policy package.  The update of the selinux-policy package causes a trigger of the old policycoreutils-python which can not handle the new syntax.

If you run service reinstall selinux-policy-targeted, it should not generate this error.

This will not happen in the future, so I am closing this as cantfix.


Note You need to log in before you can comment on or make changes to this bug.