Bug 517502 - Creation of custom channel label with a numeral at the beginning succeeds despite what instructions say
Summary: Creation of custom channel label with a numeral at the beginning succeeds des...
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server
Version: 530
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Michael Mráka
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: 462714
TreeView+ depends on / blocked
 
Reported: 2009-08-14 12:08 UTC by Milan Zázrivec
Modified: 2014-07-04 13:23 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-04 13:23:55 UTC


Attachments (Terms of Use)

Description Milan Zázrivec 2009-08-14 12:08:14 UTC
Description of problem:
In Satellite 5.3.0 webui, there are following instructions for custom channel
creation:
...
Channel name and label are required. They each must be at least 6 characters in length. Labels must begin with a letter, contain only lowercase letters, hyphens ('-'), periods ('.'), underscores ('_'), and numerals.
...

Creation of custom channel with a numeral at the beginning of channel label
succeeds though.

I'm not sure whether the channel creation logic or the instructions are
wrong, nonetheless the logic and the instructions do not seem consistent.

Version-Release number of selected component (if applicable):
Satellite 5.3.0

How reproducible:
Always

Steps to Reproduce:
1. Satellite 5.3.0, navigate to custom channel creation page.
2. Read the instructions
3. Try to create a custom channel with a numeral at the beginning of
channel label.
  
Actual results:
Creation succeeds.

Expected results:
Either the instructions or the channel creation logic should be corrected.

Additional info:
N/A


Note You need to log in before you can comment on or make changes to this bug.