Bug 517516 - iconv transliteration does not works
Summary: iconv transliteration does not works
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc
Version: 11
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Andreas Schwab
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-14 13:01 UTC by DaLiV
Modified: 2009-08-18 07:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-18 07:00:27 UTC


Attachments (Terms of Use)

Description DaLiV 2009-08-14 13:01:41 UTC
Description of problem:
iconv not doing transliterate

Version-Release number of selected component (if applicable):
fc11:
glibc-2.10.1-4.x86_64
glibc-2.10.1-4.i686
glibc-common-2.10.1-4.x86_64

FC10:
glibc-common-2.9-3.x86_64
glibc-2.9-3.i686
glibc-2.9-3.x86_64


How reproducible:
every time

Steps to Reproduce:
1. echo Тест | LANG=ru_RU.UTF-8 iconv -f UTF-8 -t ascii//translit
  
Actual results:
????

Expected results:
Test

Additional info:
possible other languages also have similar problem

Comment 1 Andreas Schwab 2009-08-17 12:12:31 UTC
There are no cyrillic characters in ASCII.  Transliteration does not convert between scripts.

Comment 2 DaLiV 2009-08-17 17:09:03 UTC
thera also have no other languages specific letters as umlauts in german, 
echo Füße | LANG=de_DE.UTF-8 iconv -f UTF-8 -t ascii//translit
result Fuesse, howewer there is not in ascii table letters ü and ß ... so it's bug ...

Comment 3 DaLiV 2009-08-17 17:22:07 UTC
or polish:
echo Žluťoučký kůň | LANG=pl_PL.UTF-8 iconv -f UTF-8 -t ascii//translit
result Zlutoucky kun , that also was not in latin characters ...

Be sure that your answer correspond to declaration of package you have included for maintain : 
libiconv is part of glibc , iconv functionality defined on http://www.gnu.org/software/libiconv/

i'm understand - easiest way to say it's not a bug,...

Comment 4 DaLiV 2009-08-17 17:37:23 UTC
for latest iconv do 

git clone git://git.savannah.gnu.org/libiconv.git 

and you will get full source of iconv  - and you will see that in your source is missed many files related to many encodings ...

Comment 5 Andreas Schwab 2009-08-18 07:00:27 UTC
These are all latin characters.


Note You need to log in before you can comment on or make changes to this bug.