Bug 517587 - two .desktop files for ddd
Summary: two .desktop files for ddd
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: ddd
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-14 20:21 UTC by Edward Sheldrake
Modified: 2009-08-17 15:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-17 15:35:17 UTC


Attachments (Terms of Use)

Description Edward Sheldrake 2009-08-14 20:21:18 UTC
Description of problem:
In rawhide, the ddd package contains ddd.desktop (from source tarball) and also fedora-ddd.desktop (from extra source).

Version-Release number of selected component (if applicable):
ddd-3.3.12-4.fc12

How reproducible:
Check the filelists.

Steps to Reproduce:
1. Install ddd
2. Check the Programming menu in GNOME
3.
  
Actual results:
Two entries, "DDD Debugger" and "Data Display Debugger"

Expected results:
Only one entry for ddd.

Additional info:
Doesn't "DDD Debugger" expand to "Data Display Debugger Debugger"? The file from the tarball has a different Name and Comment, and also doesn't have Debugger in the Category list.

Comment 1 Gwyn Ciesla 2009-08-17 15:35:17 UTC
Looks like upstream started bundling their own.

Fixed, thanks.


Note You need to log in before you can comment on or make changes to this bug.