Bug 517639 - Microcode SW error detected - iwl5000-firmware
Summary: Microcode SW error detected - iwl5000-firmware
Keywords:
Status: CLOSED DUPLICATE of bug 514099
Alias: None
Product: Fedora
Classification: Fedora
Component: iwl5000-firmware
Version: 11
Hardware: x86_64
OS: Linux
low
high
Target Milestone: ---
Assignee: Nicolas Chauvet (kwizart)
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-15 14:03 UTC by Eric Donkersloot
Modified: 2009-08-27 13:34 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-27 13:34:29 UTC


Attachments (Terms of Use)

Description Eric Donkersloot 2009-08-15 14:03:52 UTC
Description of problem:

When downloading at high speeds (~ 2.5 Mbit/s) using the wireless adapter the connection fails at some point:

Aug 15 15:19:34 vaiopro kernel: iwlagn: Read index for DMA queue txq_id (2) index 1 is out of range [0-256] 13 6
Aug 15 15:19:34 vaiopro kernel: iwlagn: Read index for DMA queue txq_id (2) index 255 is out of range [0-256] 13 6
Aug 15 15:19:34 vaiopro kernel: iwlagn: Microcode SW error detected.  Restarting 0x2000000.
Aug 15 15:19:34 vaiopro kernel: Registered led device: iwl-phy0:radio
Aug 15 15:19:34 vaiopro kernel: Registered led device: iwl-phy0:assoc
Aug 15 15:19:34 vaiopro kernel: Registered led device: iwl-phy0:RX
Aug 15 15:19:34 vaiopro kernel: Registered led device: iwl-phy0:TX

The only way to get the interface up-and-running after the failure is to manually turn the adapter off and on again.


Version-Release number of selected component (if applicable):

iwl5000-firmware-8.24.2.12-1.fc11.noarch

How reproducible:

Always

Steps to Reproduce:
1. Download at maximum speeds
2. Tail the messages log
3. 
  
Actual results:

Wireless adapter needs to be restarted

Expected results:

No restart

Additional info:

Sony Vaio BZ12XN
Network controller: Intel Corporation Wireless WiFi Link 5100

Comment 1 Nicolas Chauvet (kwizart) 2009-08-15 15:58:33 UTC
Do you have reported the problem to the intel iwlwifi bugzilla ?

Comment 2 Eric Donkersloot 2009-08-16 08:35:31 UTC
No, I haven't done that yet. Will do this asap.

Comment 4 Vinod Kutty 2009-08-26 04:38:50 UTC
I've been experiencing similar probs for months on a Dell E6500 w/ Intel 5300 agn. Unfortunately, in order to diagnose the issue, Intel wants the iwlagn module loaded with debugging options that produce a lot of output (a couple hundred MB per day or so when I tried it). 

More importantly, my experience has been that the problem never occurs when debugging options are turned on 8-(

Comment 5 Eric Donkersloot 2009-08-27 12:29:02 UTC
This report seems a duplicate of bug 514099

Comment 6 John W. Linville 2009-08-27 13:34:29 UTC

*** This bug has been marked as a duplicate of bug 514099 ***


Note You need to log in before you can comment on or make changes to this bug.