Bug 517648 - Trouble seeking in .wav files, elapsed time erratic
Summary: Trouble seeking in .wav files, elapsed time erratic
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gstreamer
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Deji Akingunola
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-15 15:54 UTC by James Ettle
Modified: 2009-10-26 11:58 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-10-26 11:58:01 UTC


Attachments (Terms of Use)

Description James Ettle 2009-08-15 15:54:13 UTC
Description of problem:
exaile cannot seek through simple PCM .wav files, and nor does the progress bar grow or show a change of time.

Version-Release number of selected component (if applicable):
exaile-0.2.14-3.fc11.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Attempt to play a .wav file in exaile.

Comment 1 James Ettle 2009-09-09 17:32:43 UTC
Changing to gstreamer, rhythmbox is also somewhat confused by .wav files, although in its case it will seek and shows increasing time --- but the time display gets reset to zero during seeks.

Comment 2 James Ettle 2009-09-09 17:33:12 UTC
Version-Release number of selected component (if applicable):
gstreamer-0.10.24-1.fc11.x86_64
rhythmbox-0.12.3-1.fc11.x86_64

Comment 3 Bastien Nocera 2009-10-08 16:05:52 UTC
Does Totem seek through those files properly?

Try with the latest gstreamer, gstreamer-plugins-base and gstreamer-plugins-good.

Comment 4 James Ettle 2009-10-14 17:03:21 UTC
OK, I've upgraded to gstreamer-plugins-good-0.10.16-1.fc11.x86_64; all the others are the latest on Koji. Totem seems to be behaving properly. So I guess this could be two separate bugs in the ways rhythmbox and exaile are using the gstreamer API.

Comment 5 James Ettle 2009-10-26 11:42:15 UTC
Still present with:

gstreamer-0.10.25-1.fc12.x86_64
gstreamer-0.10.25-1.fc12.i686
rhythmbox-0.12.5-7.fc12.x86_64
exaile-0.3.0.1-1.fc12.noarch
gstreamer-python-0.10.16-1.fc12.x86_64

Comment 6 Bastien Nocera 2009-10-26 11:58:01 UTC
You don't mention the version of gstreamer-plugins-good, which is far more important than the version of gstreamer-python.

If the problem still happens in Rhythmbox and/or Exaile with the updated plugins, file bugs against those players. Given that Totem handles it properly, this is unlikely to be a GStreamer problem.

Closing this.


Note You need to log in before you can comment on or make changes to this bug.