Bug 517711 - Please rebuild it with openal-soft
Summary: Please rebuild it with openal-soft
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: supertuxkart
Version: rawhide
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
Assignee: Gwyn Ciesla
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-16 08:44 UTC by Thomas Kowaliczek
Modified: 2009-08-18 18:45 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-17 18:12:04 UTC


Attachments (Terms of Use)

Description Thomas Kowaliczek 2009-08-16 08:44:42 UTC
Hello please rebuild your package with openal-soft you can find it in testing repo
for f10/f11/f12

Comment 1 Hans de Goede 2009-08-16 09:54:56 UTC
As discussed in bug 515109, openal using packages should only be rebuild using openal-soft-devel instead of openal-devel for F-12.

Thomas, I know your English isn't the best, but please try to understand, were not
going to blindly rebuild all openal using packages for F-11 and F-10. Instead the
F-10 and F-11 openal-soft should NOT have the Obsoletes for regular openal (and a conflicts for openal-devel), like the initial versions for F-12 used to have.

So please remove (unpush) the current openal-soft from F-10 / F-11 updates
testing and do a new version without the Obosoletes / Provides for regular
openal (and with a conflicts for openal-devel instead).

Thank You!

Regards,

Hans


p.s.

As a demonstration of why it is a bad idea to switch to openal-soft for
F-11 and F-10 see bug 517721

Comment 2 Gwyn Ciesla 2009-08-17 13:34:13 UTC
Agreed, not rebuilding.  Will do so if it demonstrably fixes a bug. . .

Comment 3 Hans de Goede 2009-08-17 15:08:19 UTC
(In reply to comment #2)
> Agreed, not rebuilding.  Will do so if it demonstrably fixes a bug. . .  

Jon,

In F-12 openal-soft will replace openal (it obsoletes it). So please rebuild otherwise supertuxkart won't work due to broken deps.

Note that Fedora is not the first distribution to do this, Debian (you know
those ultra conservative guys) and Ubuntu have already switched over 2 years ago.

Comment 4 Gwyn Ciesla 2009-08-17 15:29:27 UTC
Ah, my mistake, I thought this bug was against F-11.

I'd be happy to rebuild, but this is one of a few of my pacakges that are FTFBS due to the new freeglut.  I'm still working on it.  Any pointers would be great. I tried your suggestion of not building the Demos, but I'm not having much luck.

Comment 5 Hans de Goede 2009-08-17 18:12:04 UTC
(In reply to comment #4)
> I'd be happy to rebuild, but this is one of a few of my pacakges that are FTFBS
> due to the new freeglut.  I'm still working on it.  Any pointers would be
> great. I tried your suggestion of not building the Demos, but I'm not having
> much luck.  

Ah, ok, the problem is not really with freeglut, but with supertuxkart itself.
supertuxkart needs libGLU, bit is msissing -lGLU from its linking command.

The old freeglut was linked to libGLU itself, so dragged it in for supertuxkart fixing things, but this no longer happens.

I've fixed this and done the rebuild for openal-soft (and tested things still work), closing.

p.s.

astromenace needs a rebuild in rawhide for openal-soft too I think. It only links
against freealut, which is why no bug was filed, but most apps which use freealut, also use some openal functions directly. Probably the same story as the
GLU freeglut one here, astromenace only links against freealut, which brings in
openal, while since it uses openal methods directly it should also link against
openal.

Anyways, its a good idea to rebuild astromenace. Jon, I've put this on my todo
(rebuilding astromenace). So if you plan on doing this yourself, please let me know before tomorrow morning CET, as I will then do the rebuild (and run some tests).

Comment 6 Gwyn Ciesla 2009-08-17 18:22:25 UTC
Thanks Hans, please go ahead.  I've got several freeglut packages to rebuild that I've been banging my head against the wall on, and I'd love to rip off^H^H^H^H^H^H^Hlearn from your patches.

Comment 7 Hans de Goede 2009-08-18 09:10:53 UTC
(In reply to comment #6)
> Thanks Hans, please go ahead.  I've got several freeglut packages to rebuild
> that I've been banging my head against the wall on, and I'd love to rip
> off^H^H^H^H^H^H^Hlearn from your patches.  

Done.

This was a nasty critter. Not a freeglut issue (again) but one with OpenGL
headers. Luckily I already encountered this issue while rebuilding vegastrike
for the new openal, so I knew how to fix it. Back then I thought this was a vegastrike bug, now I'm not so sure anymore so I've filed bug 517959 for the opengl header issue (and worked around it for now).

I've also re-spinned the source tarbal as I noticed that astromenace included
an old copy of glext.h which is under a non Free license.

Last, once all that was fixed, it did not work well with openal-soft, updating
to a recent git snapshot of openal-soft fixes this, see bug 517973.

p.s.

Feel free to ask for help if you've got any other FTBFS bugs open which you cannot fix yourself.

Comment 8 Gwyn Ciesla 2009-08-18 18:45:35 UTC
Thanks!  I may do that.  This brings me down to 3, one of which is opengl-related, I think, one is libgnomeui (?!) and one is . . .well, cernlib, and I contacted Patrice, the former maintainer.


Note You need to log in before you can comment on or make changes to this bug.