Bug 517739 - PackageKit fails to update a package installed as i586 and x86_64
Summary: PackageKit fails to update a package installed as i586 and x86_64
Keywords:
Status: CLOSED DUPLICATE of bug 517674
Alias: None
Product: Fedora
Classification: Fedora
Component: PackageKit
Version: 11
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-16 13:51 UTC by Aleksandar Kanchev
Modified: 2009-08-20 15:32 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-20 15:32:39 UTC


Attachments (Terms of Use)

Description Aleksandar Kanchev 2009-08-16 13:51:52 UTC
Description of problem:
I have Fedora 11 x86_64 installed. I need some i586 (non-x86_64) libraries for stuff like skype. I've noticed that PackageKit fails to update my system if it has to update a package which is installed as i586 and as x86_64. For example:

Test Transaction Errors:   file /etc/fonts/conf.avail/25-unhint-nonlatin.conf from install of fontconfig-2.7.1-1.fc11.x86_64 conflicts with file from package fontconfig-2.6.99.behdad.20090508-1.fc11.i586
  file /etc/fonts/conf.avail/30-metric-aliases.conf from install of fontconfig-2.7.1-1.fc11.x86_64 conflicts with file from package fontconfig-2.6.99.behdad.20090508-1.fc11.i586
  file /etc/fonts/conf.avail/30-urw-aliases.conf from install of fontconfig-2.7.1-1.fc11.x86_64 conflicts with file from package fontconfig-2.6.99.behdad.20090508-1.fc11.i586
  file /etc/fonts/conf.avail/45-latin.conf from install of fontconfig-2.7.1-1.fc11.x86_64 conflicts with file from package fontconfig-2.6.99.behdad.20090508-1.fc11.i586
  file /etc/fonts/conf.avail/60-latin.conf from install of fontconfig-2.7.1-1.fc11.x86_64 conflicts with file from package fontconfig-2.6.99.behdad.20090508-1.fc11.i586
  file /etc/fonts/conf.avail/65-fonts-persian.conf from install of fontconfig-2.7.1-1.fc11.x86_64 conflicts with file from packag...

This problem does not occur if I run 'yum update' from the console. So after PackageKit failed, I ran 'yum update' and updated my system.


Version-Release number of selected component (if applicable):
PackageKit-yum-plugin-0.4.8-2.fc11.x86_64
gnome-packagekit-2.27.3-1.fc11.x86_64
PackageKit-0.4.8-2.fc11.x86_64
PackageKit-gtk-module-0.4.8-2.fc11.x86_64
PackageKit-yum-0.4.8-2.fc11.x86_64
PackageKit-gstreamer-plugin-0.4.8-2.fc11.x86_64
PackageKit-glib-0.4.8-2.fc11.x86_64


How reproducible:
Install for example old versions of 'fontconfig.i586' and 'fontconfig.x86_64' and wait for PackageKit to find the updates.

Comment 1 Richard Hughes 2009-08-20 15:32:39 UTC

*** This bug has been marked as a duplicate of bug 517674 ***


Note You need to log in before you can comment on or make changes to this bug.