Bug 517766 - digikam crashes on launch
Summary: digikam crashes on launch
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: digikam
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Steven M. Parrish
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-16 23:48 UTC by John Schmitt
Modified: 2010-08-22 21:38 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-08-22 21:38:30 UTC


Attachments (Terms of Use)
strace of crash (3.28 MB, text/plain)
2009-08-16 23:48 UTC, John Schmitt
no flags Details


Links
System ID Priority Status Summary Last Updated
KDE Software Compilation 230504 None None None Never

Description John Schmitt 2009-08-16 23:48:17 UTC
Created attachment 357590 [details]
strace of crash

Description of problem:
The splash screen shows up and it scans my albums then crashes.


Version-Release number of selected component (if applicable):
digikam-0.10.0-1.fc11.x86_64

How reproducible:
always

Steps to Reproduce:
1. launch digikam
2.
3.
  
Actual results:

 digiKam (digikam), signal SIGSEGV
0x0000003bd10a3fa1 in nanosleep () from /lib64/libc.so.6
[Current thread is 1 (Thread 0x7f09a4718820 (LWP 31202))]

Thread 5 (Thread 0x7f099d9e7910 (LWP 31203)):
#0  0x0000003bd1c0b2f9 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x0000003bdd05ad7b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x000000000063bb9b in ?? ()
#3  0x0000003bdd059cd5 in ?? () from /usr/lib64/libQtCore.so.4
#4  0x0000003bd1c0686a in start_thread () from /lib64/libpthread.so.0
#5  0x0000003bd10de39d in clone () from /lib64/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7f0995e81910 (LWP 31262)):
#0  0x0000003bd1c0b2f9 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x0000003bdd05ad7b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x000000371ff2c372 in Digikam::LoadSaveThread::run() () from /usr/lib64/libdigikamcore.so.1
#3  0x0000003bdd059cd5 in ?? () from /usr/lib64/libQtCore.so.4
#4  0x0000003bd1c0686a in start_thread () from /lib64/libpthread.so.0
#5  0x0000003bd10de39d in clone () from /lib64/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7f0995480910 (LWP 31263)):
#0  0x0000003bd1c0b2f9 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x0000003bdd05ad7b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x000000371ff2c372 in Digikam::LoadSaveThread::run() () from /usr/lib64/libdigikamcore.so.1
#3  0x0000003bdd059cd5 in ?? () from /usr/lib64/libQtCore.so.4
#4  0x0000003bd1c0686a in start_thread () from /lib64/libpthread.so.0
#5  0x0000003bd10de39d in clone () from /lib64/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7f0981c48910 (LWP 31264)):
#0  0x0000003bd1c0b57d in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007f0986e3d5c1 in ?? () from /usr/lib64/libxine.so.1
#2  0x0000003bd1c0686a in start_thread () from /lib64/libpthread.so.0
#3  0x0000003bd10de39d in clone () from /lib64/libc.so.6
#4  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7f09a4718820 (LWP 31202)):
[KCrash Handler]
#5  0x00007f097f949373 in shmat () from /usr/lib64/xine/plugins/1.26/xineplug_vo_out_xcbshm.so
#6  0x00007f0986e45e22 in _x_load_video_output_plugin () from /usr/lib64/libxine.so.1
#7  0x00007f0986e45eb9 in xine_open_video_driver () from /usr/lib64/libxine.so.1
#8  0x00007f09940796b7 in ?? () from /usr/lib64/kde4/plugins/phonon_backend/phonon_xine.so
#9  0x00007f0994079cd4 in ?? () from /usr/lib64/kde4/plugins/phonon_backend/phonon_xine.so
#10 0x00007f0994061f5c in ?? () from /usr/lib64/kde4/plugins/phonon_backend/phonon_xine.so
#11 0x000000371cc33e52 in ?? () from /usr/lib64/libphonon.so.4
#12 0x000000371cc389d6 in ?? () from /usr/lib64/libphonon.so.4
#13 0x000000371cc37ba4 in Phonon::VideoWidget::VideoWidget(QWidget*) () from /usr/lib64/libphonon.so.4
#14 0x000000371cc3900e in ?? () from /usr/lib64/libphonon.so.4
#15 0x000000371cc39270 in Phonon::VideoPlayer::VideoPlayer(Phonon::Category, QWidget*) () from /usr/lib64/libphonon.so.4
#16 0x000000000062f219 in ?? ()
#17 0x00000000005e2a74 in ?? ()
#18 0x000000000060b004 in ?? ()
#19 0x00000000005f1eb2 in ?? ()
#20 0x00000000005ffda7 in ?? ()
#21 0x00000000006600b2 in ?? ()
#22 0x0000003bd101ea2d in __libc_start_main () from /lib64/libc.so.6
#23 0x0000000000453439 in _start ()

Comment 1 Rex Dieter 2009-08-17 00:05:18 UTC
rpm -q kdelibs qt
please.

Comment 2 John Schmitt 2009-08-17 02:20:43 UTC
$ rpm -q kdelibs qt
kdelibs-4.2.4-6.fc11.x86_64
qt-4.5.2-1.fc11.x86_64

Comment 3 John Schmitt 2009-08-27 20:54:28 UTC
Is there anything I can do to move this along?  

I just did a big update of KDE et al, and tried digikam again with no change in behaviour:

digikam-0.10.0-2.fc11.x86_64
kdegraphics-4.3.0-1.fc11.x86_64
qt-4.5.2-2.fc11.x86_64
kdelibs-4.3.0-6.fc11.x86_64


$ gdb digikam                                 
GNU gdb (GDB) Fedora (6.8.50.20090302-37.fc11)
Copyright (C) 2009 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.           
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"   
and "show warranty" for details.                                             
This GDB was configured as "x86_64-redhat-linux-gnu".                        
For bug reporting instructions, please see:                                  
<http://www.gnu.org/software/gdb/bugs/>...                                   
Missing separate debuginfos, use: debuginfo-install digikam-0.10.0-2.fc11.x86_64
(gdb) run                                                                       
Starting program: /usr/bin/digikam                                              
[Thread debugging using libthread_db enabled]                                   
[New Thread 0x7ffff04a6910 (LWP 4176)]                                                                                                                                                               
[New Thread 0x7fffe7fff910 (LWP 4177)]                                                                                                                                                               
[New Thread 0x7fffe75fe910 (LWP 4178)]                                                                                                                                                               
[New Thread 0x7fffdcb3d910 (LWP 4179)]                                                                                                                                                               
                                                                                                                                                                                                     
Program received signal SIGSEGV, Segmentation fault.                                                                                                                                                 
0x00007fffd694a373 in shmat () from /usr/lib64/xine/plugins/1.26/xineplug_vo_out_xcbshm.so
(gdb) thread apply all backtrace

Thread 5 (Thread 0x7fffdcb3d910 (LWP 4179)):
#0  0x0000003bd1c0b57d in pthread_cond_timedwait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x00007fffe57d95c1 in ?? () from /usr/lib64/libxine.so.1
#2  0x0000003bd1c0686a in start_thread () from /lib64/libpthread.so.0
#3  0x0000003bd10de39d in clone () from /lib64/libc.so.6
#4  0x0000000000000000 in ?? ()

Thread 4 (Thread 0x7fffe75fe910 (LWP 4178)):
#0  0x0000003bd1c0b2f9 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x0000003098a5ad7b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x000000334e7351a2 in Digikam::LoadSaveThread::run() () from /usr/lib64/libdigikamcore.so.1
#3  0x0000003098a59cd5 in ?? () from /usr/lib64/libQtCore.so.4
#4  0x0000003bd1c0686a in start_thread () from /lib64/libpthread.so.0
#5  0x0000003bd10de39d in clone () from /lib64/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 3 (Thread 0x7fffe7fff910 (LWP 4177)):
#0  0x0000003bd1c0b2f9 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x0000003098a5ad7b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x000000334e7351a2 in Digikam::LoadSaveThread::run() () from /usr/lib64/libdigikamcore.so.1
#3  0x0000003098a59cd5 in ?? () from /usr/lib64/libQtCore.so.4
#4  0x0000003bd1c0686a in start_thread () from /lib64/libpthread.so.0
#5  0x0000003bd10de39d in clone () from /lib64/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 2 (Thread 0x7ffff04a6910 (LWP 4176)):
#0  0x0000003bd1c0b2f9 in pthread_cond_wait@@GLIBC_2.3.2 () from /lib64/libpthread.so.0
#1  0x0000003098a5ad7b in QWaitCondition::wait(QMutex*, unsigned long) () from /usr/lib64/libQtCore.so.4
#2  0x000000000063e29b in ?? ()
#3  0x0000003098a59cd5 in ?? () from /usr/lib64/libQtCore.so.4
#4  0x0000003bd1c0686a in start_thread () from /lib64/libpthread.so.0
#5  0x0000003bd10de39d in clone () from /lib64/libc.so.6
#6  0x0000000000000000 in ?? ()

Thread 1 (Thread 0x7ffff71d9820 (LWP 4173)):
#0  0x00007fffd694a373 in shmat () from /usr/lib64/xine/plugins/1.26/xineplug_vo_out_xcbshm.so
#1  0x00007fffe57e1e22 in _x_load_video_output_plugin () from /usr/lib64/libxine.so.1
#2  0x00007fffe57e1eb9 in xine_open_video_driver () from /usr/lib64/libxine.so.1
#3  0x00007fffe5a6a6b7 in ?? () from /usr/lib64/kde4/plugins/phonon_backend/phonon_xine.so
#4  0x00007fffe5a6acd4 in ?? () from /usr/lib64/kde4/plugins/phonon_backend/phonon_xine.so
#5  0x00007fffe5a52f5c in ?? () from /usr/lib64/kde4/plugins/phonon_backend/phonon_xine.so
#6  0x000000309ec33e52 in ?? () from /usr/lib64/libphonon.so.4
#7  0x000000309ec389d6 in ?? () from /usr/lib64/libphonon.so.4
#8  0x000000309ec37ba4 in Phonon::VideoWidget::VideoWidget(QWidget*) () from /usr/lib64/libphonon.so.4
#9  0x000000309ec3900e in ?? () from /usr/lib64/libphonon.so.4
#10 0x000000309ec39270 in Phonon::VideoPlayer::VideoPlayer(Phonon::Category, QWidget*) () from /usr/lib64/libphonon.so.4
#11 0x0000000000631e69 in ?? ()
#12 0x00000000005e51f4 in ?? ()
#13 0x000000000060e744 in ?? ()
#14 0x00000000005f5b42 in ?? ()
#15 0x00000000006033b7 in ?? ()
#16 0x00000000006639ff in ?? ()
#17 0x0000003bd101ea2d in __libc_start_main () from /lib64/libc.so.6
#18 0x0000000000453659 in _start ()

Comment 4 Rex Dieter 2009-08-27 22:17:30 UTC
Sorry, I can't reproduce or debug this much myself based on the backtraces.

My only best advice would be to report this to digikam's upstream developers @ bugs.kde.org

Comment 5 Steven M. Parrish 2009-09-13 01:30:40 UTC
Thank you for taking the time to report this issue.

This is an issue that needs to be addressed by the upstream developers. Please report this at http://bugs.kde.org and then add the upstream report information to this report.  We will monitor the upstream report for a resolution to this issue, and will review any bug fixes that become available for consideration in future updates.

Setting status to NEEDINFO, and awaiting upstream bug report URL for tracking.

Thanks in advance.

-- 
Steven M. Parrish - KDE Triage Master
                  - PackageKit Triager
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers

Comment 6 John Schmitt 2010-03-12 21:28:12 UTC
I upgraded to Fedora 12 and I see the same symptoms.  See https://bugs.kde.org/show_bug.cgi?id=230504

Comment 7 Alex Lancaster 2010-06-17 23:18:08 UTC
I get something similar to this, although it just hangs at the "Reading kipi plugins" stage.

Comment 8 Rex Dieter 2010-08-22 21:38:30 UTC
The original report, following the upstream bug, seems have something to do with phonon/xine-backend issues running inside a vnc session.  ugh.

Workaround was to reconfigure phonon to use gstreamer.  I think that's probably as good as it's going to get.


Note You need to log in before you can comment on or make changes to this bug.