Bug 517854 - Version of CMAN in repos is dependant on an older kernel
Summary: Version of CMAN in repos is dependant on an older kernel
Keywords:
Status: CLOSED DUPLICATE of bug 516925
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: cman-kernel
Version: 4
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Christine Caulfield
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-17 14:00 UTC by Rob Marti
Modified: 2009-08-17 14:04 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-17 14:04:41 UTC


Attachments (Terms of Use)

Description Rob Marti 2009-08-17 14:00:08 UTC
Description of problem:
When attempting to install the latest cman on a newly installed and fully patched server, up2date reports an "Unresolvable chain of dependencies" involving cman-kernel.


Version-Release number of selected component (if applicable):
kernel-smp-2.6.9-89.0.7.EL
cman-kernel-smp  2.6.9-56.7.el4_8.4      requires /lib/modules/2.6.9-89.0.3.ELsmp
cman-kernel-smp-2.6.9-56.7.el4_8.4       requires kernel-smp = 2.6.9-89.0.3.EL

How reproducible:
Every time


Steps to Reproduce:
1.  Install RHEL4 server.
2.  Run updates to get latest kernel.
3.  Attempt to install cman.
  
Actual results:
[root@LnxLumRes01t ~]# up2date -i cman

Fetching Obsoletes list for channel: rhel-i386-es-4...

Fetching Obsoletes list for channel: rhel-i386-es-4-cluster...

Fetching rpm headers...
########################################

Name                                    Version              Rel               Arch
----------------------------------------------------------------------------------------
cman                                    1.0.27              1.el4               i686


Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
cman-kernel-smp  2.6.9-56.7.el4_8.4      requires /lib/modules/2.6.9-89.0.3.ELsmp
cman-kernel-smp-2.6.9-56.7.el4_8.4       requires kernel-smp = 2.6.9-89.0.3.EL


The following packages were added to your selection to satisfy dependencies:
Package                                Required by
----------------------------------------------------------------------------
cman-kernel-smp-2.6.9-56.7.el4_8.4.i686 cman-1.0.27-1.el4                       cman-kernel-modules

[root@LnxLumRes01t ~]# uname -a
Linux LnxLumRes01t 2.6.9-89.0.7.EL #1 Wed Aug 5 14:00:47 EDT 2009 i686 i686 i386 GNU/Linux


Expected results:
cman successfully installs.

Additional info:

Comment 1 Rob Marti 2009-08-17 14:04:41 UTC

*** This bug has been marked as a duplicate of bug 516925 ***

Comment 2 Rob Marti 2009-08-17 14:04:56 UTC
Sorry, should've looked closer.


Note You need to log in before you can comment on or make changes to this bug.