Bug 517902 - xorg-x11-drv-ati backtrace with modeset enabled
Summary: xorg-x11-drv-ati backtrace with modeset enabled
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-server
Version: rawhide
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-17 19:01 UTC by James Laska
Modified: 2018-04-11 08:30 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-09-10 17:15:53 UTC


Attachments (Terms of Use)
smoltprofile.txt (6.59 KB, text/plain)
2009-08-17 19:01 UTC, James Laska
no flags Details
/var/log/Xorg.1.log (42.87 KB, text/plain)
2009-08-17 19:02 UTC, James Laska
no flags Details
/var/log/dmesg (40.90 KB, text/plain)
2009-08-17 23:51 UTC, James Laska
no flags Details
/var/log/Xorg1.log (-logverbose 9) (39.76 KB, text/plain)
2009-08-18 00:08 UTC, James Laska
no flags Details
dmesg (42.49 KB, text/plain)
2009-08-19 12:06 UTC, James Laska
no flags Details
Xorg1.log (-logverbose 5) (47.09 KB, text/plain)
2009-08-19 12:06 UTC, James Laska
no flags Details

Description James Laska 2009-08-17 19:01:54 UTC
Created attachment 357694 [details]
smoltprofile.txt

Description of problem:

Attempting to login to gdm with a fully up2date rawhide system results in X backtrace.

Version-Release number of selected component (if applicable):

 * xorg-x11-drv-ati-6.12.2-21.fc12.i686
 * kernel-2.6.31-0.125.4.2.rc5.git2.fc12.i686

How reproducible:

 * Everytime with or without selinux

Steps to Reproduce:
 1. Install Rawhide from F12 NetworkManager test day live image
 2. yum -y update # to latest rawhide content
 3. Reboot and attempt to login @ gdm prompt
  
Actual results:

 * I am returned back to a gdm login prompt.  Inspecting an Xorg.1.log from `startx -- :1` yields:

(II) RADEON(0): Acceleration enabled
(==) RADEON(0): DPMS enabled
(II) RADEON(0): Set up textured video
(EE) RADEON(0): failed to set mode: Operation not permitted(EE) RADEON(0): failed to set mode: Operation not permitted(II) RADEON(0): RandR 1.2 enabled, ignore the following RandR disabled message.
(--) RandR disabled
record: RECORD extension enabled at configure time.
record: This extension is known to be broken, disabling extension now..
record: http://bugs.freedesktop.org/show_bug.cgi?id=20500

Backtrace:
0: /usr/bin/X(xorg_backtrace+0x3c) [0x80a431c]
1: /usr/bin/X [0x80a7b16]
2: [0x2d640c]
3: /usr/lib/xorg/modules/extensions/libglx.so [0x3b0393]
4: /usr/lib/xorg/modules/extensions/libglx.so [0x3a43b2]
5: /usr/bin/X(InitExtensions+0x85) [0x80c8ae5]
6: /usr/bin/X [0x8062bf8]
7: /lib/libc.so.6(__libc_start_main+0xe6) [0x82cb36]
8: /usr/bin/X [0x8062981]

Expected results:

 * X should allow login without error.

Additional info:

 * Workaround - booting with "nomodeset modeset=0 radeon.modeset=0" works around the problem

Comment 1 James Laska 2009-08-17 19:02:32 UTC
Created attachment 357695 [details]
/var/log/Xorg.1.log

Comment 2 James Laska 2009-08-17 23:51:38 UTC
Created attachment 357723 [details]
/var/log/dmesg

Comment 3 James Laska 2009-08-18 00:08:23 UTC
Created attachment 357724 [details]
/var/log/Xorg1.log (-logverbose 9)

Comment 4 Matěj Cepl 2009-08-18 12:20:50 UTC
I don't see anything hardware specific in the backtrace. Reassigning to Xorg server component.

Comment 5 Jérôme Glisse 2009-08-18 14:25:38 UTC
Does it works better with this one :
http://people.freedesktop.org/~glisse/xorg-x11-drv-ati-6.12.2-21.fc12.i686.rpm

Comment 6 James Laska 2009-08-18 16:24:28 UTC
(In reply to comment #5)
> Does it works better with this one :
> http://people.freedesktop.org/~glisse/xorg-x11-drv-ati-6.12.2-21.fc12.i686.rpm  

The reported problem does not occur with the test package

Comment 7 James Laska 2009-08-19 12:06:09 UTC
Created attachment 357925 [details]
dmesg

(In reply to comment #6)
> (In reply to comment #5)
> > Does it works better with this one :
> > http://people.freedesktop.org/~glisse/xorg-x11-drv-ati-6.12.2-21.fc12.i686.rpm  
> 
> The reported problem does not occur with the test package  

Correction ... I am still seeing this problem with the supplied package.  I'm not sure if I incorrectly tested this earlier, or if there is another failure case.  Uploading dmesg + Xorg.1.log

Comment 8 James Laska 2009-08-19 12:06:31 UTC
Created attachment 357926 [details]
Xorg1.log (-logverbose 5)

Comment 9 Jérôme Glisse 2009-08-21 15:17:46 UTC
Updated package same url can you try ?

Comment 10 James Laska 2009-08-21 17:18:48 UTC
Retested with updated package.  I have booted with modesetting enabled and logged into the desktop without error.

# cat /proc/cmdline 
ro root=/dev/mapper/luks-7d254875-eb15-4bb5-93e1-bc44bbfe079f rhgb quiet SYSFONT=latarcyrheb-sun16 LANG=en_US.UTF-8 rd_plytheme=charge

# echo $DISPLAY
:0.0

# grep -i kms /var/log/Xorg.0.log
(II) [KMS] Kernel modesetting enabled.

Comment 11 James Laska 2009-09-10 14:01:46 UTC
I'm no longer seeing this issue ... but am seeing bug#518962.  Should I close this issue out?

Comment 12 Adam Williamson 2009-09-10 17:01:13 UTC
it looks like that trace comes somewhat later than this one did, right? that would indicate this one's fixed, I think, so probably close it yep.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers


Note You need to log in before you can comment on or make changes to this bug.