Bug 517907 - Too many notification windows (1 per restart or logout-requiring update)
Too many notification windows (1 per restart or logout-requiring update)
Status: CLOSED DUPLICATE of bug 517476
Product: Fedora
Classification: Fedora
Component: kpackagekit (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Steven M. Parrish
Fedora Extras Quality Assurance
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-08-17 16:04 EDT by Grégoire Paris
Modified: 2009-08-18 04:11 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-08-17 17:07:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot showing the bug (78.13 KB, image/png)
2009-08-17 16:06 EDT, Grégoire Paris
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 202214 None None None Never

  None (edit)
Description Grégoire Paris 2009-08-17 16:04:51 EDT
Description of problem:
If 3 packages require a system restart, and 4 other require a logout, 7
notification window appear on top of each other.
I would rather expect one or two windows with a summary.

Version-Release number of selected component (if applicable): 0.4.1.1-2.fc11


How reproducible: very often


Steps to Reproduce:
1. Juste wait for a couple of restart or logout-requiring updates to happen
2. approve the update
3.
  
Actual results: There are as many notification windows as updates


Expected results: One window requiring the a logout if there are only logout-requiring updates, or a restart if there is a restart-requiring update


Additional info: I already reported the bug on bugs.kde.org and was told that it was Fedora's problem.
Comment 1 Grégoire Paris 2009-08-17 16:06:42 EDT
Created attachment 357700 [details]
Screenshot showing the bug
Comment 3 Rex Dieter 2009-08-17 16:13:03 EDT
Yeah, there's a relevant PackageKit bug for numerous restart requests too, don't have that handy offhand.
Comment 4 Kevin Kofler 2009-08-17 17:07:51 EDT

*** This bug has been marked as a duplicate of bug 517476 ***
Comment 5 Oliver Henshaw 2009-08-17 17:13:00 EDT
I think the "fedora problem" mentioned is about the timing of update notifications, not the number of them. See bug #513755.

I'm not sure whether any consensus has been reached on whether kpackagekit or the PackageKit backend are responsible for delaying the notifications until the update is complete.
Comment 6 Richard Hughes 2009-08-18 04:11:32 EDT
(In reply to comment #5)
> I'm not sure whether any consensus has been reached on whether kpackagekit or
> the PackageKit backend are responsible for delaying the notifications until the
> update is complete.  

There's nothing in the PackageKit spec about timing, so the frontend has to queue these, not the daemon or backend.

Note You need to log in before you can comment on or make changes to this bug.