Bug 517951 - [FOCUS] DM multipath kernel driver version too old
Summary: [FOCUS] DM multipath kernel driver version too old
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: device-mapper-multipath
Version: 5.4
Hardware: x86_64
OS: All
medium
high
Target Milestone: rc
: ---
Assignee: Ben Marzinski
QA Contact: Gris Ge
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-18 06:30 UTC by IBM Bug Proxy
Modified: 2011-01-13 23:01 UTC (History)
21 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
The kernel driver of device-mapper multipath could appear to be old and SAN boot could fail, because the version testing of the driver was not correct. Version testing is now implemented correctly.
Clone Of:
Environment:
Last Closed: 2011-01-13 23:01:41 UTC


Attachments (Terms of Use)
Ported+Tested patch. (3.22 KB, text/plain)
2009-08-21 18:10 UTC, IBM Bug Proxy
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2011:0074 normal SHIPPED_LIVE device-mapper-multipath bug fix and enhancement update 2011-01-12 17:22:03 UTC
IBM Linux Technology Center 55489 None None None Never

Description IBM Bug Proxy 2009-08-18 06:30:33 UTC
=Comment: #0=================================================
Venkateswarara Jujjuri <jvrao@us.ibm.com> - 

SAN Booted MRG 1.2 Alpha on fully up-to-date RHEL 5.3 system. ... 
and seeing issue with the multipath tools.


[root@elm9m86 ~]# uname -a
Linux elm9m86 2.6.31-rc5.3.el5rt #1 SMP PREEMPT RT Tue Aug 11 08:52:22 EDT 2009 x86_64 x86_64 x86_64
GNU/Linux

[root@elm9m86 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 5.3 (Tikanga)


[root@elm9m86 ~]# rpm -qa|grep mapper
device-mapper-event-1.02.28-2.el5
device-mapper-1.02.28-2.el5
device-mapper-multipath-0.4.7-23.el5_3.4
device-mapper-1.02.28-2.el5

[root@elm9m86 ~]# 

[root@elm9m86 ~]# multipath -ll
DM multipath kernel driver version too old
    ^^^^^^^^^^^^^^^^^^^^^^

Comment 1 IBM Bug Proxy 2009-08-20 19:01:46 UTC
------- Comment From sekharan@us.ibm.com 2009-08-20 14:56 EDT-------
Looks like the following patch need to be ported.
http://git.kernel.org/?p=linux/storage/multipath-tools/.git;a=commit;h=d0d111d16e8af297111dc05ec84ddf06e9a109f1

Comment 2 IBM Bug Proxy 2009-08-21 18:10:52 UTC
Created attachment 358268 [details]
Ported+Tested patch.


------- Comment on attachment From jvrao@us.ibm.com 2009-08-21 14:09 EDT-------


I have ported and tested the community patch as mentioned in the comment#7.
The port was onto multipath-tools-0.4.7.rhel5.13 source (device-mapper-multipath-0.4.7-23.el5.src.rpm)

Comment 3 John Kacur 2009-09-21 16:19:20 UTC
Could someone please verify whether jvrao's patch was applied to the multipath-tools and if we can close this bug?

thanks

Comment 4 IBM Bug Proxy 2009-10-13 06:21:02 UTC
------- Comment From jvrao@us.ibm.com 2009-10-13 02:13 EDT-------
(In reply to comment #10)
> Could someone please verify whether jvrao's patch was applied to the
> multipath-tools and if we can close this bug?
>
> thanks
>

Hi Any update on this? Is this into RHEL 5.4?

Comment 5 Clark Williams 2009-10-13 15:19:35 UTC
no update yet

Comment 6 Clark Williams 2009-10-15 21:07:17 UTC
Reassigning to Lana (documentation) so we can put a MRG 1.2 Release Note out for this (no way to get it into RHEL5.4 for MRG release).

Lana, we need to make sure that we have a Release Note documenting the bogus warning issued by the device-mapper-multipath tool for RHEL5 when booting the MRG v2 kernel.

Comment 7 IBM Bug Proxy 2009-10-15 21:22:32 UTC
------- Comment From jvrao@us.ibm.com 2009-10-15 17:17 EDT-------
(In reply to comment #13)
> Reassigning to Lana (documentation) so we can put a MRG 1.2 Release Note out
> for this (no way to get it into RHEL5.4 for MRG release).
>
> Lana, we need to make sure that we have a Release Note documenting the bogus
> warning issued by the device-mapper-multipath tool for RHEL5 when booting the
> MRG v2 kernel.
>

I think it is more than a documentation issue. Warning is bogus alright but it fails the command. This goes to an extent, where one can't SAN boot the MRG 1.2 on RHEL5.4 based system. The workaround is to get the SRPM, apply the patch, replace /sbin/multipath and /sbin/multipath.static, install MRG 1.2 RPMS and then proceed.

Thanks,
JV

Comment 8 Clark Williams 2009-10-16 14:18:24 UTC
I did not realize that the command failed, just thought it was a warning.
Reassigning...

Comment 9 Clark Williams 2009-10-19 13:54:24 UTC
Reassigned to RHEL (per tcoughlin)

Comment 11 Clark Williams 2010-03-29 20:49:38 UTC
Do we have any pending update on this?

Comment 12 Clark Williams 2010-04-12 19:30:37 UTC
ping

Comment 13 Ben Marzinski 2010-04-19 13:44:15 UTC
Patch applied.

Comment 17 Gris Ge 2010-10-26 06:08:57 UTC
Reproduced this bug with kernel 2.6.33.7-rt29.45.el5rt, multipath 0.4.7-34.el5
Got the same error as customer.

device-mapper-multipath-0.4.7-39.el5 fixed this problem.

Comment 18 Eva Kopalova 2010-11-30 11:41:32 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The kernel driver of device-mapper multipath could appear to be old and SAN boot could fail, because the version testing of the driver was not correct. Version testing is now implemented correctly.

Comment 22 errata-xmlrpc 2011-01-13 23:01:41 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2011-0074.html


Note You need to log in before you can comment on or make changes to this bug.