Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 518001 - Different block styles by different entrance [NEEDINFO]
Summary: Different block styles by different entrance
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pidgin
Version: 5.4
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Warren Togami
QA Contact: desktop-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-18 11:52 UTC by Mark Xie
Modified: 2014-06-03 12:49 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-03 12:49:06 UTC
Target Upstream Version:
pm-rhel: needinfo? (yxie)


Attachments (Terms of Use)

Description Mark Xie 2009-08-18 11:52:37 UTC
Description of problem:
The block style will be different when block the buddies by 2 way:
1) block a user by click it with right mouse -->block
2) block the user by "Tools -> Privacy -> Block all users"

By the first method, your status will be offline at the side of your blocked buddy. But by the second method, the blocked user still can find you are online, you just can't receive message from the blocked buddy.

This issue happens on MSN and Google Talk, but for ICQ, the appearence will be the same on the buddy side by the 2 methods.

Version-Release number of selected component (if applicable):
libpurple-2.5.9-1.el5
pidgin-2.5.9-1.el5

How reproducible:
100%

Steps to Reproduce:
1.Block a MSN or GTalk buddy by right click it.
2.Check your status at the side of the blocked buddy.
3.Unblock it by right click.
4.Block the buddy by "Tools -> Privacy -> Block all users"
5.Check your status at the side of the blocked buddy.
 
Actual results:
Your friend will find you are offline at step 2.
Your friend still can find you are online at step 4.

Expected results:
Your friend will find you are offline at step 2.
Your friend will find you are offline at step 4.

Additional info:

Comment 2 Stu Tomlinson 2009-11-20 02:48:14 UTC
"Block All Users" doesn't work on MSN at all, this is a known limitation of Pidgin & libpurple privacy implementation on MSN.

The only options that are valid on MSN are "Allow only the users below" and "Block only the users below"

This is just an FYI for now, I know it needs improving.

Comment 4 RHEL Program Management 2014-03-07 13:54:12 UTC
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Comment 5 RHEL Program Management 2014-06-03 12:49:06 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).


Note You need to log in before you can comment on or make changes to this bug.