Bug 518013 - pyxattr in EPEL 5 is broken according to rdiff-backup 1.2.8
Summary: pyxattr in EPEL 5 is broken according to rdiff-backup 1.2.8
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: pyxattr
Version: el5
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Marcin Zajaczkowski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-08-18 13:29 UTC by Till Maas
Modified: 2010-10-10 18:02 UTC (History)
4 users (show)

Fixed In Version: pyxattr-0.4.0-2.el5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-10-10 18:02:30 UTC


Attachments (Terms of Use)

Description Till Maas 2009-08-18 13:29:33 UTC
Description of problem:

I compiled rdiff-backup 1.2.8 for EPEL to make it work with Fedora. If I run rdiff-backup on a CentOS 5.3 machine with EPEL 5, I get this error:

| Warning: Your version of pyxattr (unknown) has broken support for extended
| attributes on symlinks. If you choose not to upgrade to a more recent version,
| you may see many warning messages from listattr().

Version-Release number of selected component (if applicable):
pyxattr-0:0.2.1-4.el5.i386

How reproducible:
always

Steps to Reproduce:
1.  build rdiff-backup 1.2.8 for EPEL
2.  rdiff-backup /tmp/ /var/tmp/foo
  
Actual results:
Error message about broken pyxattr

Expected results:
no error message

Additional info:
On F10 with a up to date pyxattr, I do not see this error.

If you update the EPEL package, please also create egg-info:
https://fedoraproject.org/wiki/Packaging/Python/Eggs#Upstream_Eggs

Comment 1 Till Maas 2009-08-18 13:38:57 UTC
A rebuilded pyxattr from F10 works for EL5 and provides the egg-info.

Comment 2 Marcin Zajaczkowski 2009-08-18 16:40:52 UTC
Current version of rdiff-backup in EPEL is 1.0.5-2.el5. pyxattr 0.2.1 is compatible with it. Acording to EPEL policy there is no need to put there latest versions. At first it should be stable.
As you already noticed version 0.4.0 taken from Fedora repository should work fine. If you would like to have pyxattr-0.4.0 in EPEL repository anyway please enter a bug against rdiff-backup to update to the latest stable version (1.2.x is stable for awhile). It will give a reason to upgrade pyxattr library as well (to be compatible with other package).

Comment 3 Kevin Fenzi 2009-08-18 16:46:43 UTC
See bug 466720 for the rdiff-backup update. 

The sticky issue is that rdiff-backup 1.0.5 and 1.2.x don't talk to each other. 
Such upgrades are frowned on in EPEL (if not forbidden). 
We are working on a policy for doing such incompatible updates now. This would include notifying via the announce list and leaving lots of time for folks to notice the new version before it's pushed live. 

I would love to update rdiff-backup, but it's going to cause some people pain... ;(

Comment 4 Till Maas 2009-08-18 19:50:26 UTC
(In reply to comment #2)

> fine. If you would like to have pyxattr-0.4.0 in EPEL repository anyway please
> enter a bug against rdiff-backup to update to the latest stable version (1.2.x
> is stable for awhile). It will give a reason to upgrade pyxattr library as well
> (to be compatible with other package).  

Imho the existence of a serious bug in pyxattr is reason enough to update it, even if it may not be triggered by other software in EPEL. From the git log it might be enough to just update to 0.2.2, if you like this more:

http://git.k1024.org/pyxattr.git/?a=commitdiff;h=e3fdf4a1e2b631116d043ce34851274c996013df

(In reply to comment #3)
> See bug 466720 for the rdiff-backup update. 
> 
> The sticky issue is that rdiff-backup 1.0.5 and 1.2.x don't talk to each other. 
> Such upgrades are frowned on in EPEL (if not forbidden). 

I know that there is a problem, but this question (whether or not this upgrade is allowed) is now unanswered for more than 10 months. I do not really care, what the answer is, because both answers would allow to move forward. If it cannot be upgraded, then the other option is to make both versions installable at once.
Btw. after I upgraded I noticed that the new rdiff-backup happily uses the old rdiff storage directory. I did not try to restore something, though. Therefore I do not see that this is that much a problem, because if the EPEL machines are all updated, then they can happily co-exist. And if the update is not wanted, nobody is forced to update and the old version is not maintained anymore, so there wouldn't be any updates that would conflict.

Comment 5 Fedora Update System 2009-08-19 21:08:11 UTC
pyxattr-0.4.0-2.el5 has been submitted as an update for Fedora EPEL 5.
http://admin.fedoraproject.org/updates/pyxattr-0.4.0-2.el5

Comment 6 Marcin Zajaczkowski 2009-08-19 21:09:57 UTC
I submitted it to EL-5 testing repository to be properly tested with rdiff-backup 1.0.x and 1.2.x.

Comment 7 Fedora Update System 2009-08-20 15:00:15 UTC
pyxattr-0.4.0-2.el5 has been pushed to the Fedora EPEL 5 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update pyxattr'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/EL-5/FEDORA-EPEL-2009-0319

Comment 8 Mark Chappell 2010-09-22 07:43:38 UTC
Marcin,

We're trying to get the EPEL bug queue down to a sensible size, is there a reason that this package didn't get pushed to stable?

Comment 9 Marcin Zajaczkowski 2010-09-22 20:25:24 UTC
Everything should be ok, but I wasn't able to test the new version in EPEL, so I was waiting for a sign from reporter confirming that it didn't break anything.

Comment 10 Mark Chappell 2010-09-22 20:42:41 UTC
After a year it's probably worth pushing to stable, Till, any feedback?

Comment 11 Fedora Update System 2010-10-10 18:02:25 UTC
pyxattr-0.4.0-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.