Bug 518064 - upgrading proxy from x -> rhel4 530 automatically installs monitoring
Summary: upgrading proxy from x -> rhel4 530 automatically installs monitoring
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Installer
Version: 530
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact: Red Hat Satellite QA List
URL: na
Whiteboard:
Depends On:
Blocks: 462714
TreeView+ depends on / blocked
 
Reported: 2009-08-18 16:26 UTC by wes hayutin
Modified: 2012-03-17 16:53 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-17 16:53:25 UTC


Attachments (Terms of Use)

Description wes hayutin 2009-08-18 16:26:49 UTC
Description of problem:

upgrading proxy from x -> 530 automatically installs monitoring

saw the behavior on proxy 5.0 and 4.0
For example monitoring was not even around in sat 4.0.

recreate:
install proxy 4.0 on rhel 4
test to make sure it works
upgrade using the cmd-line installer to 5.3

watch the proxy monitoring packages get installed.
After they are installed you have the option of configuring the Scout.

You end up with proxy start / restart errors like

abling Spacewalk Proxy.
Shutting down rhn-proxy...
Shutting down Jabber router:                               [FAILED]
Stopping httpd:                                            [FAILED]
Stopping squid:                                            [FAILED]
Done.
Starting rhn-proxy...
Starting squid: .                                          [  OK  ]
Starting httpd:                                            [  OK  ]
Starting Jabber services                                   [  OK  ]
Starting MonitoringScout ...  
2009-08-18 12:22:23 InstallSoftwareConfig: 	!! Couldn't download NOCpulse.ini:  500 Internal Server Error

	Starting InstallSoftwareConfig ...  [ FAIL ]
2009-08-18 12:22:23 InstallSoftwareConfig: WARNING: STARTED BUT *NOT* RUNNING
2009-08-18 12:22:23 InstallSoftwareConfig: ERRORS ENCOUNTERED DURING LAST ACTION:
2009-08-18 12:22:23 InstallSoftwareConfig: 	!! Couldn't download NOCpulse.ini:  500 Internal Server Error

2009-08-18 12:22:23 MonitoringScout: NOTE: Attempting to start scout without configuration refresh
	Starting NPBootstrap ...  2009-08-18 12:22:24 NPBootstrap: 	!! ERROR FROM SHELL COMMAND: 
2009-08-18 12:22:24 NPBootstrap: 	!! STDOUT: 
2009-08-18 12:22:24 NPBootstrap: 	!! STDERR: Can't call method "get" on an undefined value at /usr/bin/npBootstrap.pl line 15.



the proxy works otherwise..

Comment 1 wes hayutin 2009-08-18 16:48:21 UTC
rhel 5 based proxies do prompt the user about monitoring, where rhel4 based proxies do NOT

Comment 2 Miroslav Suchý 2009-08-19 13:01:22 UTC
Wes, are you sure? I checked the code and manually run the code and there should not be difference in rhel4 and rhel5 in this part of code. (I did not test propper upgrade since I have no rhel4 synced here).
The configure-proxy.sh do not ask whether it should install monitoring only if
 a) you already have installed package spacewalk-proxy-monitoring
 b) you set in answer file INSTALL_MONITORING to 1 (or on command line).

Comment 4 Miroslav Suchý 2012-03-17 16:53:25 UTC
Could not reproduce any more.


Note You need to log in before you can comment on or make changes to this bug.