Bug 518107 - Update acpi sysfs to provide /sys/firmware/acpi/table/DMAR
Summary: Update acpi sysfs to provide /sys/firmware/acpi/table/DMAR
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.5
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: 5.6
Assignee: Prarit Bhargava
QA Contact: Red Hat Kernel QE team
URL:
Whiteboard:
Depends On:
Blocks: 557597
TreeView+ depends on / blocked
 
Reported: 2009-08-18 21:46 UTC by Don Dutile
Modified: 2010-08-24 13:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-08-24 13:31:45 UTC


Attachments (Terms of Use)

Description Don Dutile 2009-08-18 21:46:08 UTC
Description of problem:
One of the number one problems with Intel VTd support is that it is 100% dependent on an ACPI table called 'DMAR'.  BIOS/ACPI errors in the DMAR have
created some looooong, VTD-IOMMU debugging sessions, which could have been 
shortened if the acpi system exported the DMAR table via /sys/firmware/acpi/table/DMAR as is done upstream (& Fedora).
With the use of iasl (preferably an updated version to 2009), one can cat
the above file, input it into iasl, and decode the table in human-readable form
to confirm or deny the existence of a bad DMAR table.

Version-Release number of selected component (if applicable):


How reproducible:
Can't cat /sys/firmware/acpi/table/DMAR on RHEL5.
Can do that on F11, upstream linux.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
none, due to lack of support.
Current workaround -- install & boot an F11 installation on suspect hw;
pull the DMAR table from /sys/firmware/acpi/table/DMAR.


Expected results:
cat /sys/firmware/acpi/table/DMAR > DMAR.raw   works.
iasl -d DMAR.raw generates human readable DMAR output.


Additional info:
RHEL5's iasl is very old, and needs updating as well. 
Filing another bz for it.  It's output isn't quite correct,
thus leaves the user to wonder if DMAR is valid or not.

Comment 9 Prarit Bhargava 2010-08-24 13:31:45 UTC
You can dump the DMAR in RHEL5 via the acpidump and acpiextract utilities, and examine the DMAR using iasl as mentioned above.

Since that is the case, it is unlikely that this will be fixed for 5.6 or even 5.7 .

Closing as WONTFIX.

P.


Note You need to log in before you can comment on or make changes to this bug.